HDU - 2680-Choose the best route 最短路径模板题

Choose the best route


         One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

1
-1

#include <bits/stdc++.h>//Choose the best route
using namespace std;
#define INF 0x3f3f3f3f
int Tu[1002][1002];//存储图的信息
int dis[1002];//到源点的最短距离
int bj[1002];//标记这个点有没有访问过
int N,M,S;
void init()//数据的初始化
{
    for(int i=0; i<=N; i++)
        for(int j=0; j<=N; j++)
        {
            if(i==j)
                Tu[i][j]=0;
            else
                Tu[i][j]=INF;
        }
}
void dij()
{
    for(int i=0; i<=N; i++)
    {
        dis[i]=Tu[0][i];//源点到i点的最短距离
        bj[i]=0;//标记这个点有没有访问过
    }
    bj[0]=1;
    int flag=0;//下一个起始点
    int c=1;//保存点的个位数
    while(c<N)
    {
        int Min=INF;
        for(int i=0; i<=N; i++)
        {
            if(bj[i]==0&&dis[i]<Min)//找到下一个最短距离
            {
                Min=dis[i];
                flag=i;
            }
        }
        bj[flag]=1;//标记flag点访问过
        c++;//城市个数加
        for(int i=0;i<=N;i++)
            if(bj[i]==0&&dis[i]>dis[flag]+Tu[flag][i])//这个点没有访问过并且最短距离可以更新
            {
                dis[i]=dis[flag]+Tu[flag][i];
            }
    }
}
int main()
{
    int p,q,t,a,w;
    while(scanf("%d%d%d",&N,&M,&S)!=EOF)
    {
        init();
        while(M--)
        {
            scanf("%d%d%d",&p,&q,&t);
            Tu[p][q]=min(Tu[p][q],t);
        }
        scanf("%d",&w);
        while(w--)
        {
            scanf("%d",&a);
            Tu[0][a]=Tu[a][0]=0;
        }
        dij();
        if(dis[S]!=INF)
        printf("%d\n",dis[S]);
        else
            printf("-1\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值