PAT A1123. Is It a Complete AVL Tree (30)

1123. Is It a Complete AVL Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    

    

Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print "YES" if the tree is complete, or "NO" if not.

Sample Input 1:
5
88 70 61 63 65
Sample Output 1:
70 63 88 61 65
YES
Sample Input 2:
8
88 70 61 96 120 90 65 68
Sample Output 2:
88 65 96 61 70 90 120 68
NO
思路分析:

建立平衡二叉树,然后层序遍历输出即可。确定是否为完全二叉树的方法:利用层序遍历,加一个标志,遇到第一个有空子树的结点时置1,之后若再遇到非空结点,则说明不是完全二叉树。

题解:

#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;
const int MAX = 20;

struct Node{
	int data, h;
	Node *left, *right;
};
int seq[MAX];
int n;
bool judge = true;

Node* newnode(int x){
	Node* u = new Node;
	u->data = x;
	u->h = 1;
	u->left = u->right = NULL;
	return u;
}

int geth(Node* root){
	if(root == NULL) return 0;
	else return root->h;
}

void updateh(Node* root){
	root->h = max(geth(root->left), geth(root->right)) + 1;
}

int getf(Node* root){
	return geth(root->left) - geth(root->right);
}

void R(Node* &root){
	Node* temp = root->left;
	root->left = temp->right;
	temp->right = root;
	updateh(root);
	updateh(temp);
	root = temp;
}

void L(Node* &root){
	Node* temp = root->right;
	root->right = temp->left;
	temp->left = root;
	updateh(root);
	updateh(temp);
	root = temp;
}

void insert(Node* &root, int x){
	if(root == NULL){
		root = newnode(x);
	} 
	else{
		if(x < root->data){
			insert(root->left, x);
			updateh(root);
			if(getf(root) == 2){
				if(getf(root->left) == 1) R(root);
				else if(getf(root->left) == -1){
					L(root->left);
					R(root);
				}
			}
		}else{
			insert(root->right, x);
			updateh(root);
			if(getf(root) == -2){
				if(getf(root->right) == -1) L(root);
				else if(getf(root->right) == 1){
					R(root->right);
					L(root);
				}
			}
		}
	}
}

Node* create(){
	Node* root = NULL;
	for(int i = 0; i < n; i++){
		insert(root, seq[i]);
	}
	return root;
}

void level(Node* root){
	queue<Node*> q;
	int k = 0, num = 0;
	q.push(root);
	while(!q.empty()){
		Node* front = q.front();
		q.pop();
		printf("%d", front->data);
		if(num++ != n-1) printf(" ");
		else printf("\n");
		if(k){
			if(front->left != NULL || front->right != NULL) judge = false;
		}
		if(front->left == NULL && k == 0) k = 1;
		if(front->right != NULL && k) judge = false;
		if(front->right == NULL && k == 0) k = 1;  
	
		if(front->left != NULL) q.push(front->left);
		if(front->right != NULL) q.push(front->right);
	}
}

int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		scanf("%d", &seq[i]);
	}
	Node* root = create();
	level(root);
	if(judge) printf("YES");
	else printf("NO");
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值