04-树5 Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 20≤20) which is the total number of keys to be inserted. Then NN distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120
Sample Output 1:

70
Sample Input 2:

7
88 70 61 96 120 90 65
Sample Output 2:

88

#include<stdio.h>
#include<stdlib.h>
#include<stdlib.h>
typedef struct AVLNode *Position;
typedef Position AVLTree;
typedef struct AVLNode{
    int data;
    AVLTree Left,Right;
    int Height;
};
AVLTree NewNode(int V); 
int Max(int a,int b);
AVLTree Insert(AVLTree T,int V);
AVLTree SingleLeftRotation(AVLTree A);
AVLTree SingleRightRotation (AVLTree A);
AVLTree DoubleLeftRightRotation(AVLTree A);
AVLTree DoubleRightLeftRotation(AVLTree A);
int GetHeight(AVLTree A);
int main(){
    int N,V,i;
    AVLTree T;
    scanf("%d",&N);
    if(N>=1&&N<=20){
        scanf("%d",&V);
        T=NewNode(V);
        for(i=1;i<N;i++){
            scanf("%d",&V);
            T=Insert(T,V);
        }
        printf("%d\n",T->data);
    }
    return 0;
}
AVLTree NewNode(int V){
    AVLTree T;
    T=(AVLTree)malloc(sizeof(struct AVLNode));
    T->data = V;
    T->Left= T->Right = NULL;
    T->Height=0;
    return T; 
}
int Max(int a,int b){
    return a>b?a:b; 
}
AVLTree Insert(AVLTree T,int V){
    if(!T){
        T = NewNode(V);
    }
    else if(V<T->data){
        T->Left = Insert(T->Left,V);
        if(GetHeight(T->Left)-GetHeight(T->Right)==2){
            if(V<T->Left->data)
            T = SingleLeftRotation(T);
            else
            T = DoubleLeftRightRotation(T);
        }
    }
    else if(V>T->data){
        T->Right = Insert(T->Right,V);
        if(GetHeight(T->Left)-GetHeight(T->Right)==-2){
            if(V>T->Right->data)
            T= SingleRightRotation(T);
            else
            T= DoubleRightLeftRotation(T);
        }
    }
    T->Height = Max(GetHeight(T->Left),GetHeight(T->Right))+1;
    return T;
}
AVLTree SingleLeftRotation(AVLTree A){
    AVLTree B=A->Left;
    A->Left=B->Right;
    B->Right=A;
    A->Height=Max(GetHeight(A->Left),GetHeight(A->Right))+1;
    B->Height=Max(GetHeight(B->Left),A->Height)+1;
    return B; 
}
AVLTree SingleRightRotation (AVLTree A){
    AVLTree B=A->Right;
    A->Right = B->Left;
    B->Left = A;
    A->Height=Max(GetHeight(A->Left),GetHeight(A->Right))+1;
    B->Height=Max(GetHeight(B->Right),A->Height)+1;
    return B;
}
AVLTree DoubleLeftRightRotation(AVLTree A){
    A->Left = SingleRightRotation(A->Left);
    return SingleLeftRotation(A); 
} 
AVLTree DoubleRightLeftRotation(AVLTree A){
    A->Right = SingleLeftRotation(A->Right);
    return SingleRightRotation(A);
}
int GetHeight(AVLTree A){
    int depth1,depth2;
    if(!A){
        return 0;
    }
    else{

            depth1 = GetHeight(A->Left);
            depth2 = GetHeight(A->Right);
    }
    return depth1>depth2?depth1+1:depth2+1;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值