PAT A1122. Hamiltonian Cycle (25)

1122. Hamiltonian Cycle (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
思路分析:

首先要形成一个简单环,且经过所有结点,则意味着整个路径的结点数为图的总结点数加1,只有一个结点出现两次,且出现在队列首尾,其他结点只出现一次。

因此,根据如下步骤判断:

1.输入序列的个数不等于n+1,输出NO

2.输入序列的首尾不同,输出NO

3.输入序列中的数字除首位出现2次外,其余只能出现1次,不符合,输出NO

4.输入序列不连通,输出NO

题解:

#include <cstdio>
#include <algorithm>
using namespace std;
const int MAX = 210;

int n, m, k;
int g[MAX][MAX] = {0}, query[MAX], counts[MAX] = {0};

int main(){
	scanf("%d %d", &n, &m);
	while(m--){
		int u, v;
		scanf("%d %d", &u, &v);
		g[u][v] = g[v][u] = 1; 
	}
	scanf("%d", &k);
	while(k--){
		scanf("%d", &m);
		for(int i = 0; i < m; i++){
			scanf("%d", &query[i]);
		}
		bool judge = true;
		if(m != n+1 || query[0] != query[m-1]){
			printf("NO\n");
		}else{
			fill(counts, counts+MAX, 0);
			for(int i = 0; i < m-1; i++){
				counts[query[i]]++;
			}
			for(int i = 1; i <= n; i++){
				if(counts[i] != 1){
					judge = false;
					break;
				}
			}
			if(!judge) printf("NO\n");
			else{
				for(int i = 0; i < m-1; i++){
					if(!g[query[i]][query[i+1]]){
						judge = false;
						break;
					}
				}
				if(judge) printf("YES\n");
				else printf("NO\n");
			}	
		}
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值