PAT--1122. Hamiltonian Cycle (25)

32 篇文章 0 订阅

Description

The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format “Vertex1 Vertex2”, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 … Vn

where n is the number of vertices in the list, and Vi’s are the vertices on a path.

Output Specification:

For each query, print in a line “YES” if the path does form a Hamiltonian cycle, or “NO” if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题解

给定一个无向图,以及遍历序列,判断其是否为哈密顿回路。

考虑哈密顿回路的必要条件:

  • 序列首尾相同
  • 序列长度 = 顶点个数 + 1
  • 除首尾外,不会再有相同的顶点。
  • 序列中相邻的两个顶点要求有边相连。

满足这些条件可以判断这是一条哈密顿回路。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#include <string>
#include <set>
using namespace std;

const int maxn = 200 + 10;
int n, m, k;
vector<int> G[maxn];

bool connect(int u, int v){
    for(int i = 0; i < G[u].size(); ++i){
        if(G[u][i] == v) return true;
    }
    return false;
}

bool judge(vector<int>& path){
    int len = path.size();

    if(len != n + 1) return false;
    if(path[0] != path[len - 1]) return false;

    vector<int> vis(path.begin(), path.end() - 1);
    sort(vis.begin(), vis.end());

    for(int i = 0; i < vis.size(); ++i){
        if(vis[i] != i + 1) return false;
    }

    for(int i = 0; i < path.size() - 1; ++i){
        int u = path[i], v = path[i + 1];
        if(!connect(u, v)) return false;
    }

    return true;
}


int main()
{
#ifndef ONLINE_JUDGE
freopen("data.in", "r", stdin);
#endif

    cin >> n >> m;
    int u, v;
    for(int i = 0; i < m; ++i){
        cin >> u >> v;
        G[u].push_back(v);
        G[v].push_back(u);
    }

    cin >> k;
    for(int i = 0; i < k; ++i){
        int t; cin >> t;
        vector<int> path;
        path.resize(t);
        for(int j = 0; j < t; ++j){
            cin >> path[j];
        }
        if(judge(path)) cout << "YES" << endl;
        else cout << "NO" << endl;
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值