PAT A1138. Postorder Traversal (25)

1138. Postorder Traversal (25)

时间限制
600 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:
7
1 2 3 4 5 6 7
2 3 1 5 4 7 6
Sample Output:
3
思路分析:

利用前序和中序序列建立二叉树,然后后序遍历二叉树,只输出一个结点即可。

利用前序和中序序列建立二叉树采用递归思路。首先根据前序序列的第一个元素作为根节点的值,再根据第一个元素将中序序列分为左右两段,然后对左字段递归建立二叉树作为根节点的左子树,对右字段递归建立二叉树作为根节点的右子树即可。


#include <cstdio>
#define MAX 50000

struct Node{
	int data;
	Node *left, *right;
};
int pre[MAX], in[MAX];
int n;
bool judge = true;

Node* create(int prel, int prer, int inl, int inr){
	if(prel > prer) return NULL;
	Node* root = new Node;
	root->data = pre[prel];
	int k = -1;
	for(int i = inl; i <= inr; i++){
		if(in[i] == root->data){
			k = i;
			break;
		}
	}
	if(k == -1) return NULL;
	int lnum = k - inl;
	root->left = create(prel+1, prel+lnum, inl, k-1);
	root->right = create(prel+lnum+1, prer, k+1, inr);
	return root;
}

void postorder(Node* root){
	if(root != NULL && judge){
		postorder(root->left);
		postorder(root->right);
		if(judge){
			printf("%d", root->data);
			judge = false;
		}
	} 
}

int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; i++) scanf("%d", &pre[i]);
	for(int i = 0; i < n; i++) scanf("%d", &in[i]);
	Node* root = create(0, n-1, 0, n-1);
	postorder(root);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值