PAT A1138 2019.07.31 【前中序列建树】

1138 Postorder Traversal (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

思路分析:

根据二叉树的前序、中序遍历序列,输出其后序遍历序列的第一个值

最常规的方法就是先建树、再输出

这类题型的建树函数的参数为四个下标值,在递归的时候会用到这些值、要考虑它们的实际意义

比如此题中:k-inL代表 左子树结点个数等等,这样才不会导致递归时传入错误的参数

关于二叉树 结点结构体定义、申请新结点的写法、基本遍历函数要理解并牢记,这样可以加快做题速度

#include<cstdio>
#include<iostream>
#define MAX 50010

typedef struct NODE{
	int data;
	struct NODE *left;
	struct NODE *right;
}NODE;

int n;
int pre[MAX];
int in[MAX];
int stack[MAX];
int top=-1;


NODE *create(int preL,int preR,int inL,int inR)
{
	if(preL>preR)return NULL;//若先序序列长度 <=0 则直接返回NULL 
	NODE *newNode = new NODE;
	newNode->data = pre[preL];
	int k;
	for(k=inL;k<=inR;k++)if(in[k]==pre[preL])break;//注意此处 k为小于等于 
	newNode->left=create(preL+1,preL+k-inL,inL,k-1); //注意4个下标 不要出现常数 尽量与4个参数联系起来 
	newNode->right=create(preL+k-inL+1,preR,k+1,inR);
	return newNode;
}

void postorder(NODE *root)
{
	if(root==NULL)return;
	postorder(root->left);
	postorder(root->right);
//	printf("%d",root->data);
	stack[++top]=root->data;
}

int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)scanf("%d",&pre[i]);
	for(int i=0;i<n;i++)scanf("%d",&in[i]);
	NODE *root = new NODE;
	root->left=NULL;
	root->right=NULL;
	root = create(0,n-1,0,n-1);
	postorder(root);
	printf("%d",stack[0]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值