B. Best Time to Buy and Sell Stocks(贪心系列)

Problem Description
Say you have an array for which the ith element is the price of a given stock on day i. Design an algorithm to find the maximum profit. You may complete as many transactions as you like (i.e., buy one and sell one share of the stock multiple times).

For example, there is an array [7, 1, 5, 3, 6, 4] and its answer 7. The element 7 in the array means the price of a given stock on day 0, and the element 4 means the price of the stock on day 5. The answer 7 means the maximum profit.

Note: You may not engage in multiple transactions at the same time (i.e., you must sell the stock before you buy again).

Input
An array with int elements, separated by spaces.

Output
An integer.

Sample Input
7 1 5 3 6 4

Sample Output
7

#include<bits/stdc++.h>
using namespace std;
int main(){
    long long num;
    int pre=INT_MAX;
    long long  res=0;
    while(scanf("%d",&num)==1){
        if (num>pre){
            res+=num-pre;
           
        }
         pre=num;

    }
    cout<<res;
  
   return 0;

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值