Problem Description
Say you have an array for which the ith element is the price of a given stock on day i. Design an algorithm to find the maximum profit. You may complete as many transactions as you like (i.e., buy one and sell one share of the stock multiple times).
For example, there is an array [7, 1, 5, 3, 6, 4] and its answer 7. The element 7 in the array means the price of a given stock on day 0, and the element 4 means the price of the stock on day 5. The answer 7 means the maximum profit.
Note: You may not engage in multiple transactions at the same time (i.e., you must sell the stock before you buy again).
Input
An array with int elements, separated by spaces.
Output
An integer.
Sample Input
7 1 5 3 6 4
Sample Output
7
#include<bits/stdc++.h>
using namespace std;
int main(){
long long num;
int pre=INT_MAX;
long long res=0;
while(scanf("%d",&num)==1){
if (num>pre){
res+=num-pre;
}
pre=num;
}
cout<<res;
return 0;
}