B - Carries SCU - 4437

Carries
frog has n integers a1,a2,…,an, and she wants to add them pairwise.

Unfortunately, frog is somehow afraid of carries (进位). She defines hardness h(x,y) for adding x and y the number of carries involved in the calculation. For example, h(1,9)=1,h(1,99)=2.

Find the total hardness adding n integers pairwise. In another word, find
∑1≤i<j≤nh(ai,aj)
.

Input
The input consists of multiple tests. For each test:

The first line contains 1 integer n (2≤n≤105). The second line contains n integers a1,a2,…,an. (0≤ai≤109).

Output
For each test, write 1 integer which denotes the total hardness.

Sample Input
2
5 5
10
0 1 2 3 4 5 6 7 8 9
Sample Output
1
20

  • 题意:给你n个数,求这n个数中任意两个数间想加进位了多少次
  • 题解:直接把这n个数除以 1 0 k 10^k 10k,然后把这n个数排下序,最后在这n个数中找满足相加> 1 0 k 10^k 10k的对数.k从1到9遍历一遍
#include<bits/stdc++.h>
#define mk make_pair
#define endl '\n'
#define pb pusk_back
#define _ ios::sync_with_stdio(false)
using namespace std;
typedef long long ll;
const double EPS = 1e-10;
const double PI = acos(-1);
bool SUBMIT = 1;
const int inf = 1e5+10;
int a[inf],b[inf];
int main()
{
    if(!SUBMIT)freopen("i.txt","r",stdin);else _;    
    int n;
    while(cin>>n){
        for(int i=0;i<n;i++)cin>>a[i];
        ll ans=0,m=1;
        for(int i=0;i<9;i++){
            m*=10;
            for(int j=0;j<n;j++)b[j]=a[j]%m;
            sort(b,b+n);
            int t=0;
            for(int j=n-1;j>=0;j--){
                for(;t<j;t++){
                    if(b[t]+b[j]>=m){
                        //cout<<"----"<<endl;
                        ans+=j-t;break;
                    }
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值