弱校联萌十一大决战之强力热身 B. Carries (二分)

27 篇文章 0 订阅
16 篇文章 0 订阅

B. Carries
Time Limit: 1000msMemory Limit: 65536KB 64-bit integer IO format: %lld Java class name: Main
Submit Status
frog has n integers a1,a2,…,an, and she wants to add them pairwise.

Unfortunately, frog is somehow afraid of carries (进位). She defines \emph{hardness} h(x,y) for adding x and y the number of carries involved in the calculation. For example, h(1,9)=1,h(1,99)=2.

Find the total hardness adding n integers pairwise. In another word, find
∑1≤i<j≤nh(ai,aj)
.
Input
The input consists of multiple tests. For each test:

The first line contains 1 integer n (2≤n≤105). The second line contains n integers a1,a2,…,an. (0≤ai≤109).
Output
For each test, write 1 integer which denotes the total hardness.
Sample Input
2
5 5
10
0 1 2 3 4 5 6 7 8 9
Sample Output
1
20




解析:直接暴力会TLE,假设会在2^k上产生进位,枚举k,然后二分算出在第10^k上产生进位的数的个数




AC代码:

#include <bits/stdc++.h>
using namespace std;

int a[100002], b[100002];

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk
    int n;
    long long ans, s;
    while(scanf("%d", &n) == 1){
        for(int i=0; i<n; i++) scanf("%lld", &a[i]);
        ans = 0, s = 10;
        for(int k=0; k<10; k++, s*=10){
            for(int i=0; i<n; i++) b[i] = a[i] % s;
            sort(b, b+n);
            for(int i=0; i<n; i++){
                long long t = s - b[i];
                if(b[n-1] >= t){
                    int cnt = lower_bound(b, b+n, t) - b;
                    if(cnt > i) ans += n - cnt;
                    else ans += n - (i + 1);
                }
            }
        }
        printf("%lld\n", ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值