Bzoj-1734: [Usaco2005 feb]Aggressive cows 愤怒的牛(二分+贪心)

Bzoj-1734: [Usaco2005 feb]Aggressive cows 愤怒的牛

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 628  Solved: 461
[Submit][Status][Discuss]

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

农夫 John 建造了一座很长的畜栏,它包括NN (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,...,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢

Input

* Line 1: Two space-separated integers: N and C * Lines 2..N+1: Line i+1 contains an integer stall location, xi

第一行:空格分隔的两个整数N和C

第二行---第N+1行:i+1行指出了xi的位置

Output

* Line 1: One integer: the largest minimum distance

第一行:一个整数,最大的最小值

Sample Input

5 3
1
2
8
4
9

Sample Output

3
把牛放在1,4,8这样最小距离是3

HINT

【分析】二分之二分答案。即最大值的最小化或最小值的最大化问题。

  • 将牛舍的位置排序,把第一头牛放入排序后的第一个牛舍。
  • 假设两头牛之间的距离≥d,那么,下一头牛就要放入与该牛距离满足此d的位置上。

【代码】

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1e3+5;
int n,m,x[maxn];
bool check(int d)
{
	int cow=1;		//第一头牛放在第一个位置的牛舍(牛舍按位置排序之后) 
	int minpos=x[1]+d;//距离第一个牛舍d的位置 
	for(int i=2;i<=n;i++)
	{
		if(x[i]<minpos)continue;//如果距离上一个牛舍的距离小于rgt,此情况不予考虑 
		cow++;	//遍历下一个奶牛 
		minpos=x[i]+d;//继续算位置 
	}
	return cow>=m;//m头奶牛是否全部安置完毕 
}
int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)
		scanf("%d",&x[i]);
	sort(x+1,x+1+n);
	int l=0,r=x[n]-x[1];
	while(l<=r)
	{
		int mid=l+r>>1;
		if(check(mid))l=mid+1;//这个距离可以,更新左端点的值寻找是否有更大的选择 
		else r=mid-1;//否则,此距离太大了,更新右端点的值 
	}
	printf("%d\n",r);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值