HDU 1009 FatMouse' Trade

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 

 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

 

Sample Output

13.333

31.500

 

Author

CHEN, Yue

 

 

描述:小猫有M磅的鱼,有N的仓库,就有N的守卫,然后每一个仓库,如果给他F[i]磅的鱼,守卫就会给你J[i]磅的猫粮。并且可以分开给,比如说其中一个守卫仓库里面有10磅的猫粮,但是他需要4磅的鱼。如果你给他2磅,他就会给你5磅的猫粮,所以这个就是一个明显的贪心。先换价值低的猫粮,也就是J[i]/F[i] 越大越好,是算数除,不是整除。我用了结构体,主要是想用sort函数。

代码:

#include<bits/stdc++.h>
using namespace std;

#define maxx 1001

struct st
{
   int a, b;
   double v;    
};
bool cmp(struct st x, struct st y)
{
    return x.v < y.v;
}

int main()
{
    //freopen("in.txt","r",stdin);
    int n, m, i;
    struct st num[maxx];
    while(~scanf("%d %d", &n, &m))
    {
        if(n == -1 && m == -1) break;
        for(i = 0; i < m; i++)
        {
            scanf("%d %d", &num[i].a, &num[i].b);
            num[i].v = (double)num[i].a/num[i].b*1.0;
        
        }
        sort(num+0, num+m, cmp);
        double sum = 0 ;
        for(i = m-1; i >= 0 && n > 0; i--)
        {
            
            if( n > num[i].b)
            {
                sum += num[i].a;
                n -= num[i].b;
            }
            else
            {
                sum += (double)((double)n*(double)num[i].a/(double)num[i].b*1.0);
                n = 0;
            }
        }
        printf("%.3lf\n", sum);
        
        
    }
    
    fclose(stdin);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值