关于堆的判断

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N 1000)和M 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T
#include<iostream>
using namespace std;
#define maxn 1005
#define minh -10001
int H[maxn],siz;


void init()
{
    siz=0;
    H[0]=minh;//哨所
}

void Insert(int x)
{
    siz++;
    int i;
    for(i=siz;H[i/2]>x;i/=2)
    {
        H[i]=H[i/2];
    }
    H[i]=x;
}

int Search(int x)
{
    for(int i=1;i<=siz;i++)
    {
        if(H[i]==x)
            return i;
    }
}

int main()
{
    int n,m,a,b;
    string s;
    cin>>n>>m;
    init();
    for(int i=0;i<n;i++)
    {
        cin>>a;
        Insert(a);
    }
    while(m--)
    {
        cin>>a>>s;
        if(s=="is")
        {
            cin>>s>>s;
            if(s=="root")
            {
                if(H[1]==a)
                    cout<<"T"<<endl;
                else
                    cout<<"F"<<endl;
            }
            else if(s=="parent")
            {
                cin>>s>>b;
                int x=Search(b);
                if(H[x/2]==a)
                    cout<<"T"<<endl;
                else
                    cout<<"F"<<endl;

            }
            else if(s=="child")
            {
                cin>>s>>b;
                int x=Search(a);
                if(H[x/2]==b)
                    cout<<"T"<<endl;
                else
                    cout<<"F"<<endl;
            }
        }
        else if(s=="and")
        {
            cin>>b>>s>>s;
            int x=Search(a);
            int y=Search(b);
            if(x/2==y/2)
                cout<<"T"<<endl;
            else
                cout<<"F"<<endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值