问题描述
给出两个整数集合 A 、 B A、B A、B,求出他们的交集、并集以及 B B B在 A A A中的余集。
输入格式
第一行为一个整数 n n n,表示集合 A A A中的元素个数。
第二行有 n n n个互不相同的用空格隔开的整数,表示集合 A A A中的元素。
第三行为一个整数 m m m,表示集合 B B B中的元素个数。
第四行有 m m m个互不相同的用空格隔开的整数,表示集合 B B B中的元素。
集合中的所有元素均为 i n t int int范围内的整数, n 、 m < = 1000 n、m<=1000 n、m<=1000。
输出格式
第一行按从小到大的顺序输出 A 、 B A、B A、B交集中的所有元素。
第二行按从小到大的顺序输出 A 、 B A、B A、B并集中的所有元素。
第三行按从小到大的顺序输出 B B B在 A A A中的余集中的所有元素。
样例输入
5
1 2 3 4 5
5
2 4 6 8 10
样例输出
2 4
1 2 3 4 5 6 8 10
1 3 5
样例输入
4
1 2 3 4
3
5 6 7
样例输出
1 2 3 4 5 6 7
1 2 3 4
个人思路:首先对两个数组排序;然后直接同时遍历两个数组,比较两个数组中元素值大小,做出不同的处理;如果某个数组有剩余,需要单独处理;余集则利用前面比较元素值中相等情况做的标记进行排除
#include <iostream>
#include <algorithm>
using namespace std;
int n, m;
int a[1005], b[1005];
int ans1[1005], ans2[2005];
bool vis[1005];
int main() {
cin >> n;
for (int i = 0; i < n; ++i) {
cin >> a[i];
}
cin >> m;
for (int j = 0; j < m; ++j) {
cin >> b[j];
}
sort(a, a + n);
sort(b, b + m);
int k = 0, h = 0;
int i = 0, j = 0;
while (k < n && h < m) {
//将小元素放入ans2,作为并集
if (a[k] < b[h])
{
ans2[j] = a[k];
k++;
j++;
}
if (a[k] > b[h]) {
ans2[j] = b[h];
h++;
j++;
}
//相等则放入交集、并集,并标记a数组中的元素
if (a[k] == b[h]) {
ans1[i] = a[k];
ans2[j] = a[k];
i++;
j++;
vis[k] = true;
k++;
h++;
}
}
//b数组有剩余
if (k == n && h < m) {
for (int x = h; x < m; ++x) {
ans2[j] = b[x];
++j;
}
}
//a数组有剩余
if (k < n && h == m) {
for (int x = k; x < n; ++x) {
ans2[j] = a[x];
++j;
}
}
//需要判断一下i是否大于0,如果小于0则说明无交集
if (i > 0) {
for (int x = 0; x < i; ++x) {
cout << ans1[x] << " ";
}
cout << endl;
}
//需要判断一下j是否大于0,如果小于0则说明无并集
if (j > 0) {
for (int x = 0; x < j; ++x) {
cout << ans2[x] << " ";
}
cout << endl;
}
//排除相等元素
for (int x = 0; x < n; ++x) {
if (!vis[x])
cout << a[x] << " ";
}
return 0;
}