杭电acm1027全排列(回溯算法)

Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 
Sample Input
 
 
6 411 8
 
Sample Output
 
 
1 2 3 5 6 41 2 3 4 5 6 7 9 8 11 10
 

Author
Ignatius.L
 

Recommend

We have carefully selected several similar problems for you:  1026 1038 1029 1008 1024 

注意:i表示树(回溯)的深度,count1表示第x(x=1,2,3……n)个序列。为了防止超时,不必搜索字典序大于m的序列。当count1==m时,提前结束递归。

#include <iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int a[1001];
int vis[1001];
int n;
int count1;
int fact(int i,int m1)
{
    if(i>n)
    {
        count1++;
        if(count1==m1)
        for(i=1;i<=n;i++)
        {
            if(i<n)
            printf("%d ",a[i]);
            else
            printf("%d\n",a[i]);
        }
        return 0;
    }
    for(int j=1; j<=n; j++)
    {
        if(vis[j]==0)
        {
            vis[j]=1;
            a[i]=j;
            fact(i+1,m1);
            if(count1==m1)
                return 1;
            vis[j]=0;
        }
    }
}
int main()
{
    int m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(vis,0,sizeof(vis));
        count1=0;
        fact(1,m);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值