decimal system

Problem Description

As we know , we always use the decimal system in our common life, even using the computer. If we want to calculate the value that 3 plus 9, we just import 3 and 9.after calculation of computer, we will get the result of 12.
But after learning <>,we know that the computer will do the calculation as the following steps:
1 computer change the 3 into binary formality like 11;
2 computer change the 9 into binary formality like 1001;
3 computer plus the two number and get the result 1100;
4 computer change the result into decimal formality like 12;
5 computer export the result;

In the computer system there are other formalities to deal with the number such as hexadecimal. Now I will give several number with a kind of change method, for example, if I give you 1011(2), it means 1011 is a number in the binary system, and 123(10) means 123 if a number in the decimal system. Now I will give you some numbers with any kind of system, you guys should tell me the sum of the number in the decimal system.
Input
There will be several cases. The first line of each case contains one integers N, and N means there will be N numbers to import, then there will be N numbers at the next N lines, each line contains a number with such form : X1….Xn.(Y), and 0<=Xi<Y, 1<Y<=10. I promise you that the sum will not exceed the 100000000, and there will be at most 100 cases and the 0<N<=1000.
Output
There is only one line output case for each input case, which is the sum of all the number. The sum must be expressed using the decimal system.
Sample Input

3
1(2)
2(3)
3(4)

4
11(10)
11(2)
11(3)
11(4)

Sample Output

6
23

Code:
思路:利用getline()函数一次读入一行字符串,将该字符串的内容分为x和y,然后将y进制的数x转化为对应的十进制数(乘基相加)进行求和计算

#include<iostream>
#include<string>
#include<math.h>
using namespace std;
//将y进制表示的数x转化为十进制数
int convert(int x, int y) {
 	int data, deci = 0, i = 0;
 	while (x != 0) {
  		data = x % 10;
  		deci = deci + data * pow(y, i);
  		i++;
  		x = x / 10;
	 }
 	return deci;
 //deci的值即为最终转化成的十进制数
}
int main() {
	int n;	
	int sum;
	string s, s1, s2, str1;		
	while (cin >> n) {
 		if (n <= 0 || n > 100) return 0;
 		sum = 0;
 		getline(cin, str1);//消除cin的影响
 		for (int i = 0; i < n; i++) {
  			getline(cin, s);// 需要在头文件中加<string>,一次读入一行字符串,可读入空格
  			s1 = s.substr(0, s.find('('));//s.substr(pos,count)函数,用户返回字符串s中从第pos个字符开始,
            //长为count的子串;find()函数用于返回字符在母串中的位置
 			s2 = s.substr(s.find('(') + 1, s.find(')') - s.find(')') - 1);
 			int x = atoi(s1.c_str());//s1.c_str()返回一个指向字符串的指针;
         //atoi(s1.c_str())把字符串转化为整型
 			int y = atoi(s2.c_str());
 			if (y <= 1 || y > 10) return 0;
 			sum = sum + convert(x, y);
  		}
 		if (sum > 100000000) return 0;
  		cout << sum << endl;	
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值