GPA

Problem Description

Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.
Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.
Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message “Unknown letter grade in input” will be printed.

Sample Input

B C D F
B F F C C A
D C E F 

Sample Output

2.00
1.83
Unknown letter grade in input

Code:
思路:利用switch case 语句对输入的等级进行判断并计算;注意在while(cin>>c)循环中如何退出循环[利用getchar()函数];注意除法运算时,分母不为0,否则会抛出异常

#include<iostream>
#include<iomanip>
using namespace std;
int main() {
	char c,ch;
	float sum;
	int count,point;
	float gpa;
	bool flag;
	while (1) {
		flag = true; sum = 0; count = 0; point = 0;
		while (cin >> c) {
			switch (c) {
			case'A':point = 4; count++; break;
			case'B':point = 3; count++; break;
			case'C':point = 2; count++; break;
			case'D':point = 1; count++; break;
			case'F':point = 0; count++; break;
			default:flag = false; break;
			}
			sum = sum + point;
			if ((ch = getchar()) == '\n') break;
		}
		if (flag == false) {
			cout << "Unknown letter grade in input" << endl;
		}
		else if (count == 0) {
			return 0;
		}
		else{
			gpa = sum / count;
			cout << setiosflags(ios::fixed);
			cout << setprecision(2) << gpa << endl;
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值