1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

accept code:

#include <iostream>
#include <map> 
#include <iomanip>
using namespace std;

int main()
{
	map<int,double> mp1;//存储第一行数据
	map<int,double> mp2;//存储第二行数据
	map<int,double> mp3;//存储两行数据相加之后的结果
	int k1,k2,a,b;
	cin>>k1;
	int max=-1;
	while(k1--){//输入第一组数据
		cin>>a;
		cin>>mp1[a];
		if(a>max)
		{
			max=a;
		} 
	}
	cin>>k2;
	while(k2--){//输入第二组数据
		cin>>b;
		cin>>mp2[b];
		if(b>max)//找出两组数据中键最大的值
		{
			max=b;
		} 
	}
	
	int count=0;
	for(int i=0;i<=max;i++){//将两组数据相加
		mp3[i]=mp1[i]+mp2[i];

		if(mp3[i]!=0)
			count++;
	}
	cout<<count;
	for(int j=max;j>=0;j--){//从后往前输出,map是自动从小到大排序的
		if(mp3[j]!=0)//值对应结果为0的话就不做处理
		{
//			cout<<" "<<j<<" "<<setprecision(2)<<mp3[j];//用这个函数会出现格式错误,默认格式
                                                       //是科学计数法的格式,还是用printf吧
			printf(" %d %.1f",j,mp3[j]);
		}
	}
	return 0;	
	
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

.无名之辈

1毛也是爱~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值