1003 Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

心得:pat-1003这个题目我这次是第二次写,但用的方法不一样。

第一次用的是邻接表,(邻接表写法:https://blog.csdn.net/qq_38938670/article/details/83448275)这一次是邻接矩阵,但每一次写都会有每一次的收获。在第二次写这个题时发现了一个以前没有注意到的问题,就是输入流的问题。因为我用的是邻接矩阵,所以输入数据时写法为:cin>>a>>b>>G[a][b];但这样的话把a,b,G[a][b]放到依次输入流里进行处理,但是会出现a,b的值还未 缓冲到内存单元就立马使用a,b出现错误。改为这样输入cin>>a>>b;cin>>G[a][b];就可以了。

accept code:

#include <iostream>
#include <string.h>
using namespace std;
#define inf 10000000
#define maxv 510
int n,m,c1,c2;
int G[maxv][maxv];
int team[maxv];
bool vis[maxv]={false};
int t[maxv];
int num[maxv];
int d[maxv];

void Dijkstra(int s)
{
	fill(d,d+maxv,inf);
	memset(t,0,sizeof(t));
	memset(num,0,sizeof(num));
	d[s]=0;
	t[s]=team[s];
	num[s]=1;
	for(int i=0;i<n;i++)
	{
		int u=-1,mina=inf;
		for(int j=0;j<n;j++)
		{
			if(vis[j]==false&&d[j]<mina)
			{
				mina=d[j];
				u=j;
			}	
		}	
		if(u==-1) return;
		vis[u]=true;
		for(int v=0;v<n;v++)
		{
			if(vis[v]==false&&G[u][v]!=inf)
			{
				if(d[u]+G[u][v]<d[v])
				{
					d[v]=d[u]+G[u][v];
					t[v]=t[u]+team[v];	
					num[v]=num[u];
				}
				else if(d[u]+G[u][v]==d[v])
				{
					if(t[u]+team[v]>t[v])
						t[v]=t[u]+team[v];
					num[v]+=num[u];
				}
			}
		}
	}
}

int main()
{
	fill(G[0],G[0]+maxv*maxv,inf);
	int a,b;
	cin>>n>>m>>c1>>c2;
	for(int i=0;i<n;i++)
		cin>>team[i];
	for(int i=0;i<m;i++)
	{
//		cin>>a>>b>>G[a][b];//这个地方这样写会出现错误
		cin>>a>>b;
		cin>>G[a][b];
		G[b][a]=G[a][b];
	}
	
	Dijkstra(c1);
	
	cout<<num[c2]<<" "<<t[c2]<<endl;
	return 0;	
} 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

.无名之辈

1毛也是爱~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值