PAT 1084 Broken Keyboard 散列

11 篇文章 0 订阅

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

同时遍历两个字符串,若字符不相等则原字符串中字符为坏掉的键,利用hashTable记录各字符是否已经输出。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {

    public static void main(String[] args) throws IOException {
    	BufferedReader reader=new BufferedReader(new InputStreamReader(System.in));

    	String line1=reader.readLine();
    	String line2=reader.readLine();
    	boolean[] hashTable=new boolean[128];
    	int i=0,j=0;
    	while(j<line2.length()) {
    		char c1=line1.charAt(i),c2=line2.charAt(j);
            //转为大写字符
    		if(c1>='a'&&c1<='z') c1=(char)(c1-'a'+'A');
    		if(c2>='a'&&c2<='z') c2=(char)(c2-'a'+'A');
    		if(c1==c2) {
    			i++;j++;
    		}else {//没有字符c1
    			if(!hashTable[c1]) {//尚未输出
    				System.out.print(c1);
    				hashTable[c1]=true;
    			}
    			i++;
    		}
    	}
    	//处理剩余字符
    	for(;i<line1.length();i++) {
    		char c1=line1.charAt(i);
    		if(c1>='a'&&c1<='z') c1=(char)(c1-'a'+'A');
    		if(!hashTable[c1]) {
				System.out.print(c1);
				hashTable[c1]=true;
    		}
    	}
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值