【PAT甲级】1084 Broken Keyboard(散列)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _(representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

题目大意

这题就是说键盘坏了,然后第一行给出原本要输出的字符串,第二行给出实际输出的字符串 ,然后输出坏掉的键盘字符。(不区分大小写)。

个人思路

这题是【PAT乙级】的1029,看自己刷乙级题的代码简直不忍直视什么玩意,然后就重写了一遍,几行就ok了,我当时怎么写到七十几行的。

这题输入两个字符串s1,s2,建立一个bool型数组is_broken,某个字符ascii码对应其下标,数组表示了某字符是否坏了。然后诸位比较两个字符串,如果字符串的该位相等,则两个字符串都进入下一位,如果不相等,则s1标记当前字符坏了,如果是第一次坏就输出,然后进入下一位。

代码实现

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <iostream>
using namespace std;

// 转化成大写字母
void to_upper(string &s) {
    for (int i = 0; i < s.length(); i ++) {
        if (s[i] >= 'a' && s[i] <= 'z') s[i] += 'A'-'a';
    }
}

int main() {
    // 输入
    string s1, s2;
    cin >> s1 >> s2;
    // 将键盘字母根据下标映射到is_broken上
    bool is_broken[200];
    memset(is_broken, 0, sizeof(is_broken));
    // 转化成大写字母
    to_upper(s1);
    to_upper(s2);
    // 逐位检查
    for (int pos1 = 0, pos2 = 0; pos1 < s1.length(); pos1 ++) {
        if (s1[pos1] != s2[pos2] && !is_broken[s1[pos1]]) {
            cout << s1[pos1];
            is_broken[s1[pos1]] = true;
        }
        else if (s1[pos1] == s2[pos2]) pos2 ++;
    }
    return 0;
}

总结

学习不息,继续加油

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值