POJ 2182 Lost Cows 线段树

Lost Cows

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

题意:N头牛,编号为1~N,乱序排列,从第二头牛开始依次给出每头牛前面比它编号小的头数,求从前往后每头牛编号。

分析:从后向前扫描,遇到数字a则表示该牛是剩余序列中第a+1号,查找之后删除该编号后重复操作。线段树初始化时len记录每一段内编号个数,l、r记录线段边界。查找过程中,k若不大于左子树len则向左子树递归,否则向右子树递归,并传递k在右子树中相对位置即k-seg[root*2].len,遇到叶子结点则返回结点边界值l即为原编号,递归路径中所有结点len均减一

#include<iostream>
using namespace std;
struct node {
	int l;    //线段左端点
	int r;    //线段右端点
	int len;      //对应区间内编号个数
}seg[30000];
int smaller[8000],ans[8000];


void build(int root, int l, int r)
{
	seg[root].l = l;
	seg[root].r = r;
	seg[root].len = r - l + 1;
	if (l == r) return;
	int mid = (l + r) / 2;
	build(root * 2, l, mid);
	build(root * 2 + 1, mid + 1, r);
}

int query(int root, int k)
{
	seg[root].len--;//个数减一
	if (seg[root].l == seg[root].r)	return seg[root].l;//叶子结点返回其编号
	if (k <= seg[root * 2].len)	return query(2 * root, k);//左子树中查询
	else  return query(2 * root + 1, k - seg[2 * root].len);//右子树中查询
}
int main()
{
	int N;
	cin >> N;
	for (int i = 2; i <= N; i++)
		cin >> smaller[i];
	smaller[1] = 0;
	build(1, 1, N);
	for (int i = N; i >= 1; i--)//倒序查询
		ans[i] = query(1, smaller[i] + 1);//在剩余的编号中查第smaller[i]+1个编号
	for (int i = 1; i <= N; i++)
		cout << ans[i] << endl;
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值