POJ2488 Knight's Journey 深搜DFS

A Knight's Journey

 

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意:在给定的p*q的国际棋盘上,任选一个起点,以马走日的跳法不重复地走遍棋盘上的所有方格。棋盘行号为数字,列号为字母,给出字典序最小的路径。

分析:本题关键在于求出字典序最小的路径,所以应从A1点开始进行DFS。对于各位置8个可以移动的方向应该从左至右,从上到下依次搜索,以确定字典序最小。

#include<iostream>
#include<cstring>
#include<vector>
#include<utility>
using namespace std;
int P,Q,dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},
		{1,-2},{1,2},{2,-1},{2,1}};//方向按从左至右,从上至下依次搜索 
bool vis[26][26];
vector<pair<int,int> >path;//存储已走的路径 

bool dfs(int x,int y)
{
	vis[x][y]=true;
	path.push_back(make_pair(x,y));
	
	if(path.size()==P*Q) return true;//已走遍棋盘上所有方格
	
	for(int i=0;i<8;i++)
	{
		int nx=x+dir[i][0],ny=y+dir[i][1];
		if(nx>=0&&nx<Q&&ny>=0&&ny<P&&!vis[nx][ny])
		{
			if(dfs(nx,ny))
				return true;
		}
	}
    //不能走遍则改变当前路径
	vis[x][y]=false;
	path.pop_back();
	return false;
}

int main()
{
	int n,k=1;
	cin>>n;
	while(n--)
	{
		memset(vis,0,sizeof(vis));
		path.clear();
		
		cin>>P>>Q;
		printf("Scenario #%d:\n",k++);
		if(!dfs(0,0))//从A1方格开始搜索 
		{
			cout<<"impossible"<<endl;
		}
		else
		{
			for(int i=0;i<path.size();i++)
			{
				int x=path[i].first,y=path[i].second;
				cout<<(char)('A'+x)<<(y+1);
			}
			cout<<endl;
		}
		cout<<endl;
	}
	return 0;
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值