POJ1426 Find The Multiple 深搜/广搜

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题意:对给出的任意一个正数n,求出它的一个非零倍数m,m由若干个0和1组成。

分析:简单的搜索。对所有1~200的n所求的结果m都可以由64位整数存储,只需使用long long类型存储即可。

DFS:由于long long类型可存储数字最大值为2^63-1,且10^18<2^63-1<10^19,所以递归深度最多为18。从1开始,若搜到的数字可以被n整除则退出搜索,否则在数字尾部添加0或1分别继续进行搜索。

Memory: 176K		Time: 141MS
#include<iostream>
using namespace std;
typedef long long ll;
int N;
ll ans;
bool flag;

void dfs(ll sum,int k)
{
	if(k==19||flag)//搜到19层或已搜出结果,退出
		return;
	if(sum%N==0)
	{
		flag=true;ans=sum;
		return;
	}
	dfs(sum*10,k+1);
	dfs(sum*10+1,k+1);
}

int main()
{
	while(cin>>N,N)
	{
		flag=false;
		dfs(1,0);
		cout<<ans<<endl;
	}
	return 0;
	
} 

BFS:STL队列的内存使用比较大,可采用数组模拟。每次搜索注意清空队列。

//Memory: 2876K		Time: 204MS
#include<iostream>
#include<queue>
using namespace std;
typedef unsigned long long ll;

queue<ll> que;
ll bfs(int n)
{
	
	if(n==1) return 1;
	while(!que.empty())
		que.pop();
	que.push(1);
	while(!que.empty())
	{
		ll cur=que.front();
		que.pop();
		ll n1=cur*10,n2=n1+1;
		if(n1%n==0)
			return n1;
		else 
			que.push(n1);
		if(n2%n==0)
			return n2;
		else
			que.push(n2);
	}
}
int main()
{
	int n;ll m;
	while(cin>>n,n)
	{
		ll m=bfs(n);
		cout<<m<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值