POJ1837 Balance 01背包

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

题意:一个天平,给出其左右臂共c个挂钩和g个钩码,求出将所有钩码挂上天平能使天平平衡的挂法总数。

分析:01背包问题。定义dp[i][j]:=挂上前i个钩码后能使天平达到平衡度j的挂法总数。平衡度j=0表示天平平衡,j>0表示天平向右倾斜,j<0表示天平向左倾斜,因为j不能为负数,所以取新平衡点为15*20*25=7500。

若第i个钩码挂上之前天平平衡度为j,则度i个钩码挂上之后可以达到的平衡度为j+weight[i]*hook[k],可得动态方程:

dp[i][ j+weight[i]*hook[k] ]=Σdp[i-1][j]。

#include<iostream>
using namespace std;
const int maxn=15*20*25*2;
int dp[20][maxn],hook[20],weight[20];

int main()
{
	int c,g;
	cin>>c>>g;
	for(int i=0;i<c;i++)
		scanf("%d",hook+i);
	for(int i=0;i<g;i++)
		scanf("%d",weight+i);
	dp[0][maxn/2]=1;//初始状态,不挂钩码达到平衡状态有一种方法 
	for(int i=1;i<=g;i++)
		for(int j=0;j<=maxn;j++)
			if(dp[i-1][j])//优化,第i个钩码挂入之前已达到平衡度j才继续考虑 
				for(int k=0;k<c;k++)//遍历挂钩位置 
					dp[i][j+weight[i-1]*hook[k]]+=dp[i-1][j];//新平衡度状态加上前状态方法数 
	cout<<dp[g][maxn/2];
	return 0;	
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值