11-散列2 Hashing(难点分析)

中国大学MOOC-陈越、何钦铭-数据结构-2019春

11-散列2 Hashing (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

算法分析:

简单hash表+平方探测法的应用,没什么思想,主要有几个难点:

1.题目要求单正向的平方探测,在什么情况下判断探测结束呢,数学问题,只要知道(a+n)² % n = a 便可得                                  到探测结束条件。

2.当给出M=1时,因为“1”也符合质数的定义,但规定“1”不属于质数,要特判。

/***************2019.5.20-8:20-10:34**************/
//11-散列2 Hashing 2h

#include<stdio.h>
#include<math.h>
#include<stdlib.h>

struct Hash{
	int Size;
	int *Num;
}H;

int InsertHash(int X){
	int Realkey;
	int key=X%H.Size;
	int k=0;
	while(k<=H.Size){
		Realkey=(key+pow(k*1.0,2.0));
		Realkey=Realkey%H.Size;
		if(!H.Num[Realkey]){
			H.Num[Realkey]=X;
			break;
		} 
		k++;
	}
	if(k>H.Size) Realkey=-1;
	return Realkey;
}

int IsPrime(int M){
	int i;
	for(i=2;i<=sqrt(M);i++){
		if(M%i==0) return 0;
	}
	return 1;
}

int main(){
	int i;
	int M,N;
	scanf("%d%d",&M,&N);
	i=M;
	while(!IsPrime(i)) i++;
	if(i==1) i++;
	H.Size=i;
	H.Num=(int*)malloc(H.Size*sizeof(int));
	for(i=0;i<H.Size;i++) H.Num[i]=0;
	int X,Position[N];
	for(i=0;i<N;i++){
		scanf("%d",&X);
		Position[i]=InsertHash(X);
	}
//	printf("H.size=%d\n",H.Size);
	for(i=0;i<N;i++){
		if(Position[i]!=-1) printf("%d",Position[i]);
		else printf("-");
		if(i<N-1) printf(" ");
		else printf("\n");
	}
	return 0;
} 

 

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值