pat 甲级 A1078 Hashing

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题意:输入两个数字,第一个数字是hashtable的长度,第二个数是要插入的数字的个数,第二行是要插入的数字;

要求:hashtable的长度要是素数

        数字按顺序插入

        如果数字可以插入就输出插入的下标,如果在这个长度内都没法插入的话输出"-",没法插入即要插入的位置都有数字了;

思路:

        先做一个isprime函数找出hashtable的长度,因为输入的长度不一定是素数,题目的4就不是素数,这里找到的长度应该是5

         做一个bool类型的hashtable来判断这个位置有没有被插入过

        找到长度以后,根据下标=插入数%长度写作m=num%len,有两种情况,一是可以直接插入,输出被插入的下标,第二种情况是无法插入,就要用另外一种方法,二次方勘探法(Quadratic probing),二次勘探法就是a(插入数)按(num+1^2)%len,(num+2^2)%len,(num+3^2)%len……(num+step^2)%len,直到找到未被插入的下标,这里的底数的范围是到len,如果step从0到len-1进行枚举都无法找到位置,则就说明该数没有位置可插入,一般来说,二次勘探法要+或-step^n两边进行讨论,但是题目说了,只往正向解决问题,所以就按上面那样枚举就好了。

收获:二次勘探法(Quadratic probing):
代码:

int step=1;
for(step;step<size;step++){
    int num=(m+step*step)%size;
    if(hashtable[num]==false)(即没有被插入){
        ...
    }else{
        ...
    }
}

代码:

#include<iostream>
#include<cmath>
using namespace std;
const int maxn=10010;
bool hashtable[maxn]={false};
bool isprime(int num){//判断是否为素数,找到hsize;
	if(num<=1)return false;
	int sqr=(int )sqrt(1.0*num);
	for(int i=2;i<=sqr;i++){
		if(num%i==0)return false;
	}
	return true;
}
int main(){
	int hsize,n,m;
	cin>>hsize>>n;
	while(isprime(hsize)==false){
		hsize++; 
	}
	for(int i=0;i<n;i++){
		cin>>m;
		int num=m%hsize;
		if(hashtable[num]==false){//如果没被插入;
			hashtable[num]=true;
			if(i!=0)cout<<" "<<num;
			else cout<<num;
		}else {//被插入的话就找下一个下标;
			int step=1;
			for(step;step<hsize;step++){
				num=(m+step*step)%hsize;
				if(hashtable[num]==false){
					hashtable[num]=true;
					if(i!=0)cout<<" "<<num;
					else cout<<num;
					break;//退出当前break所在循环,而不是退出所有循环;
				}
			}
			if(step>=hsize){
				if(i!=0)cout<<" -";
				else cout<<"-";
			}
		}
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值