ccf-csp认证 201312-1

注:编译器一定要选择c++11或c++14不然编译报错

试题编号: 201312-1

试题名称: 出现次数最多的数

时间限制: 1.0s
内存限制: 256.0MB

问题描述:

问题描述
  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
  
样例输入
6
10 1 10 20 30 20
样例输出
10

#include<iostream>
#include<cstdio>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
typedef pair<int, int> P;
int cmp(P a,P b){
    if(a.second==b.second)
        return a.first < b.first;
    return a.second > b.second;
}

int main(){
    vector<P> v;
    map<int, int> m;
    int n,t;
    cin >> n;
    for (int i = 0; i < n;++i){
        scanf("%d", &t);
        ++m[t];
    }
    for(auto it=m.begin();it!=m.end();++it){
        v.emplace_back(P(it->first, it->second));
    }
    sort(v.begin(), v.end(), cmp);
    cout << v[0].first ;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值