现有一式子 a / b. 你需要找出数字 c 在小数点后第一次出现的位置
Input
输入包含三个整数 a, b, c (1 ≤ a < b ≤ 105, 0 ≤ c ≤ 9).
Output
输出数字 c 第一次在小数点后出现的位置,如果 c 不在小数点后出现输出 -1
Sample Input
Input
1 2 0
Output
2
Input
2 3 7
Output
-1
Sample Output
Hint
第一组样例 : 1 / 2 = 0.5000(0) 出现在第二个位置
第二组样例 : 2 /3 = 0.6666(6) 7 没有出现,输出 -1
下面是代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cstring>
using namespace std;
int main()
{
int a,b,c;
int i;
int con;
while(~scanf("%d%d%d",&a,&b,&c))
{
for(i=1;i<=100000;i++)
{
a=a*10;
con=a/b;
a=a%b;
if(con==c)
{
printf("%d\n",i);
break;
}
}
if(i==100001)
{
printf("-1\n");
}
}
return 0;
}