比较x^y和y^x的大小

给你两个数x, y, 比较 x^y 和 y ^ x 的大小

Input

两个数 x, y, ( 1 <= x , y <= 109 )

Output

如果 x ^ y < y ^ x , 输出 “<”

如果 x ^ y > y ^ x , 输出 “>”

如果 x ^ y = y ^ x , 输出 “=”

Sample Input

Input
5 8
Output
>
Input
10 3
Output
<
Input
6 6
Output
=

Sample Output

Hint

第一个例子 5 ^ 8 =  390625, 8 ^ 5 = 32768. 输出 '>'.

第二个例子 10 ^ 3 = 1000 < 3 ^10 = 59049.

第三个例子 6 ^ 6 = 46656 = 6 ^ 6.

思路:为了使数据量变小,可以采用两边取对数来判断大小,C++使用log()函数,默认底为e

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cstring>
#include <cmath>
using namespace std;

int main()
{
    long long int x,y;
    scanf("%lld%lld",&x,&y);
    if(x==y)
        printf("=\n");
    else
    {
        if((double)y*log(x)>(double)x*log(y))
            printf(">\n");
        else if((double)y*log(x)<(double)x*log(y))
            printf("<\n");
        else
            printf("=\n");
    }
    return 0;
}

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值