尺取法

尺取法,一般是在给的一组数据中找到不大于某一个上限的“最优连续子序列” 。

给长度为n的数组和一个整数m,求总和不小于m的连续子序列的最小长度; 
这里就适合用尺取法;

 

下面是练习题:poj3061;http://poj.org/problem?id=3061 。。。。

 

Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

思路:

这里写图片描述

正如该图,黄色区域就是每次查找的范围,依次可以大概看出尺取法的查找过程; 
代码如下:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <vector>
#define MAXN 100100
#define INF 0xfffffff
using namespace std;
int a[MAXN];
int n,m,sum,num;
int main()
{
    int t,i,begin1,end1;
    scanf("%d",&t);
    while(t--)
    {
        num=INF;
        scanf("%d%d",&n,&m);
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        begin1=0;
        end1=0;
        sum=0;
        while(1)
        {
            while(begin1<n&&sum<m) //从前面开始加
            {
                sum+=a[begin1];
                begin1++;
            }
            if(sum<m)
            break;
            num=min(num,begin1-end1);开始缩小尺寸
            sum-=a[end1];//从第一个开始相减,然后把尺寸一次缩小,尺寸法的前进
            end1++;
        }
        if(num==INF)//说明没有满足求得和大于m
            printf("0\n");
        else
            printf("%d\n",num);

    }
    return 0;
}

 

  • 2
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值