1010 Radix@PTA甲级

1010 Radix(25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tagis 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

题目分析:

二分查找。

结果都转成10进制,便于比较。

这题还是非常考究细节处理能力的,一共WA了10几遍,欲哭无泪。简单提一下自己A题过程中遇到的几个坑点吧,希望有点帮助。

1. 进制范围(也就是二分的左右边界)。下限是各位最大值+1,如213可能的最小进制就是4(因为3+1);关于上限要想清楚,举题目中tag=1时为例,如果N1=11(10进制),N2=1f(未知进制),想都不用想答案是Impossible,因为f已经比11大了,再多想没意义了;如果N1=110(10进制),那么N2上限进制应该是111,对吧,借鉴N1=11的情况时。 

2. 要判断tag标定的值是否跟给的radix冲突,比如N1 = 33,N2=任意,tag=1,radix=2,直接Impossible了

3.进制转换时使用long long ,还有就是要判断越界问题,越界就是<0,多加一步判断(\坑哭)。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;

long long to_dec(char *s,int radix){
    int len = strlen(s);
    long long ans = 0;
    for(int i=0;i<len;++i){
        int val = (int)(s[i]>='0' && s[i] <= '9' ? s[i]-'0' : s[i]-'a'+10);
        if(val >= radix) return -1; //如果某一位的值跟给定的进制冲突,直接返回-1
        ans = ans*radix + val;
    }
    return ans;
}

long long solve(long long val,long long left,char *s){
    long long right = left > val ? left + 1 : val + 1;
    //cout << "left is " << left << endl;
    while(left <= right){
        long long mid = left + (right-left)/2;
        long long sum = to_dec(s,mid);
        //cout << s << ' ' << mid << endl;
        //cout << "sum is " << sum << endl;
        if(sum == val) return mid;
        else if(sum > val || sum < 0) right = mid-1;
        else if(sum < val) left = mid+1;
    }
    return -1;
}

int main(){
    char s1[13],s2[13];
    int tag,radix;
    while(~scanf("%s%s%d%d",s1,s2,&tag,&radix)){
        int left = -1; //下限
        long long val = 0; 
        int ans = -1;
        if(tag == 1){
            val = to_dec(s1,radix); //转换成10进制
            if(val == -1){
                cout << "Impossible" << endl;
                continue;
            }
            //cout << "val is " << val << endl;
            int len = strlen(s2);
            for(int i=0;i<len;++i){
                left = max(left,(int)(s2[i]>='0' && s2[i]<='9'?s2[i]-'0':s2[i]-'a'+10));
            }
            ans = solve(val,left?left+1:2,s2);
        }
        else{
            val = to_dec(s2,radix);
            if(val == -1){
                cout << "Impossible" << endl;
                continue;
            }
            //cout << "val is " << val << endl;
            int len = strlen(s1);
            for(int i=0;i<len;++i){
                left = max(left,(int)(s1[i]>='0' && s1[i]<='9'?s1[i]-'0':s1[i]-'a'+10));
            }
            ans = solve(val,left?left+1:2,s1);
        }
        if(ans == -1) cout << "Impossible" << endl;
        else cout << ans << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值