1017 Queueing at Bank@PTA

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

 

 题目分析:

1.将时间换算成秒,边界分别是8*3600 和 17*3600。

2. 只要顾客到达时间在17点之前,就能接受服务,队伍排到17点之后也没关系。

3. 不要忘记加上8点之前到达的顾客的等待时间,他们在排队之前也要等待银行开门。

4.到达时间晚于17点的直接略去。

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <vector>
#include <set>
#include <stack>
#include <iomanip>

using namespace std;

struct Node{
	int a_time; //到达时间
	int p; //受服务时间
}cus[10003]; //顾客

int lines[103]; //服务窗口,记录的是该窗口服务完最近一个顾客时的时间

bool cmp(const Node &a,const Node &b){
	return a.a_time < b.a_time;
} 

int main(){
	int n,k;
	scanf("%d%d",&n,&k);

	int HH,MM,SS,P;
	for(int i=0;i<n;++i){
		scanf("%d:%d:%d%d",&HH,&MM,&SS,&P);
		// int a_time = ;
		cus[i].a_time = HH*3600 + MM*60 + SS;
		cus[i].p = P*60;
	}
	sort(cus,cus+n,cmp);

	int total = 0;
	int num = 0;
	memset(lines,-1,sizeof(lines)); //值为-1时代表该窗口还没有顾客

	for(int i=0;i<n;++i){
		if(cus[i].a_time > 17*3600) break;
		sort(lines,lines+k); //需要每次sort,找到最早服务完顾客的窗口
		
		if(cus[i].a_time <= 8*3600){
			if(lines[0] == -1){
				total += 8*3600-cus[i].a_time;
				lines[0] = 8*3600 + cus[i].p;
			}
			else{
				total += lines[0]-8*3600;
				lines[0] += cus[i].p;
				// continue;
			}
		}
		else{
			if(lines[0] <= cus[i].a_time){
				lines[0] = cus[i].a_time + cus[i].p;
				// continue;
			}
			else{
				total += lines[0]-cus[i].a_time;
				lines[0] += cus[i].p;
			}
		}
		++num;
	}
	// cout << "total is " << total << endl;
	// cout << "num is " << num << endl;
	if(num == 0) cout << "0.0" << endl;
	else printf("%.1lf\n",(double)total/num/60.0);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值