nyoj 991 Registration system (map)

Registration system

时间限制: 1000 ms  |  内存限制:65535 KB
难度: 2
 
描述

  A new e-mail service "Berlandesk" is going to be opened in Berland in the near future.

 The site administration wants to launch their project as soon as possible, that's why they

 ask you to help. You're suggested to implement the prototype of site registration system. 

The system should work on the following principle.

Each time a new user wants to register, he sends to the system a request with his name.

 If such a name does not exist in the system database, it is inserted into the database, and 

the user gets the response OK, confirming the successful registration. If the name already 

exists in the system database, the system makes up a new user name, sends it to the user 

as a prompt and also inserts the prompt into the database. The new name is formed by the

 following rule. Numbers, starting with 1, are appended one after another to name (name1,

 name2, ...), among these numbers the least i is found so that namei does not yet exist in

 the database.


 
输入
  The first line contains number n (1 ≤ n ≤ 105). The following n lines contain the requests to the system. Each request is a non-empty line, and consists of not more than 1000 characters, which are all lowercase Latin letters.
输出
Print n lines, which are system responses to the requests: OK in case of successful registration, or a prompt with a new name, if the requested name is already taken.
样例输入
  4
  abacaba
  acaba
  abacaba
  acab
样例输出
  OK
  OK
  abacaba1
  OK
/**
    分析:该题是,判断一个新输入字符串是否属于原先字符串序列
          ①"不属于" : 打印"OK"表示插入成功
          ②"属于"  : 判断是第几次出现该串(序列号)  -->  并打印:"该串" + 序列号 
    方法:map <string, int>
    模板:
        map <string, int> my_map;
        pair <map <string, int> :: iterator, bool> pr;
        
        pr = my_map.insert (map <string, int> (str, 0));
        if (!pr.second)  
        {
            ++ my_map [str];
            cout <<str <<my_map [str] <<endl; 
        } 
        else
        {
            cout <<"OK" <<endl;
        }
**/

 C/C++代码实现:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <stack>
#include <queue>
#include <map>

using namespace std;

int N;

string str;

int main () {
    ~scanf ("%d", &N);
    map <string, int> my_map;
    pair <map <string, int> :: iterator, bool> pr;
    
    while (N --) {
        cin >>str;
        pr = my_map.insert (pair <string, int> (str, 0));
        if (!pr.second) { // 插入失败 
            my_map [str] ++;
            cout <<str <<my_map [str] <<endl;
        } else {
            printf ("OK\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值