最小生成树

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.  Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.  Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.  The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28


题目大意:
给定一个N村庄和一个N^2的邻接矩阵表示每两个村庄间的距离,求将这N个点联通所需的最小电线长度  。。
思路:典型的最小生成树,我用的prim算法,就是开始随便取一个点,找出这个点和为加入的哪个点距离最短,再将那个点也加入到被选中的
集合中,反复重复这个过程直到将所有点加入到被选中集合
C语言AC代码:

时间内存结果语言
16MS240KAcceptedC
#include<stdio.h>
#define Max 100010
int dis[150][150],sum,n;
void prim()
{
	int s[150],d[150],i,j,min,index;
	for(i=0;i<n;i++)
	{
		s[i]=0;
		d[i]=dis[0][i];
	}
	s[0]=1;
	for(i=1;i<n;i++)
	{
		min=Max;
		for(j=0;j<n;j++)
		{
			if(!s[j]&&d[j]<min)
			{
				min=d[j];
				index=j;
			}
		}
		s[index]=1;
		sum+=min;
		for(j=0;j<n;j++)
		{
			if(!s[j]&&d[j]>dis[index][j])
				d[j]=dis[index][j];
		}
	}
}
int main()
{
	int i,j;
	while(scanf("%d",&n)!=-1)
	{
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				scanf("%d",&dis[i][j]);
		sum=0;
		prim();
		printf("%d\n",sum);
	}
	return 0;
}

借鉴代码:

#include<stdio.h>
#include<stdlib.h>
struct stu{
	int x,y,l;
}s[10005];
int f[105];
int cmp(const void*a,const void*b)
{
	struct stu *c,*d;
	c=(struct stu*)a;
	d=(struct stu*)b;
	return c->l-d->l;
}
int find(int x)
{
	if(f[x]!=x)
		f[x]=find(f[x]);
	return f[x];
}
int min(int a,int b)
{
	return a<b?a:b;
}
void Union(int x,int y)
{
	int xx=find(x);
	int yy=find(y);
	f[xx]=f[yy]=f[x]=f[y]=min(xx,yy);
}
int main()
{
	int n,a[105][105],i,j,k,sum;
	while(scanf("%d",&n)!=EOF)
	{
		k=0;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				scanf("%d",&a[i][j]);
				s[k].x=i;
				s[k].y=j;
				s[k++].l=a[i][j];
			}
		qsort(s,k,sizeof(s[0]),cmp);
		for(i=1;i<=n;i++)
			f[i]=i;
		sum=0;
		for(i=0;i<k;i++)
		{
			if(find(s[i].x)==find(s[i].y))
				continue;
			else
			{
				Union(s[i].x,s[i].y);
				sum+=s[i].l;
			}
		}
		printf("%d\n",sum);
	}
	return 0;}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值