zoj 2412 Farm Irrigation

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

 
Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE
then the water pipes are distributed like
 
Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

<b< dd="">

Output

For each test case, output in one line the least number of wellsprings needed.

<b< dd="">

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

<b< dd="">

Sample Output

2

3

解题思路:    搜索应用,只要注意处理两种水管相连接的情况,该题我的想法是不同型号的水管一个数组,用四个数分别表示该型号水管的四个方向,不等于零时间表示该方向可以连接,从a到k一次排列,组成一个二维数组。每次搜索一个点时间需要遍历四个方向,以此判断四个方向是否有水管和他本身相连,如果有相连的,就继续往下搜索,不然终止递归。本人处理思路有点不好理解,表达能力有限,不再过多介绍,不过思路是可以实现的。

代码:

#include<stdio.h>
#include<string.h>
int a[11][4]={1,2,0,0,0,2,3,0,1,0,0,4,0,0,3,4,0,2,0,4,1,0,3,0,1,2,3,0,1,2,0,4,1,0,3,4,0,2,3,4,1,2,3,4};
int a1[4][2]={0,-1,-1,0,0,1,1,0};
int m,n,x;
int b[55][55];	
char s[55][55];
void dfs(int x1,int y1)
{ 
	int i,nx,ny,z;
	z=0;
	for(i=0;i<4;i++)
	{
        nx=x1+a1[i][0];
        ny=y1+a1[i][1];
        if(nx<0||ny<0||nx>=m||ny>=n)
           continue;
		 if(b[nx][ny]==0&&i<2)
         {
           if(a[s[nx][ny]-'A'][i+2]!=0&&a[s[x1][y1]-'A'][i]!=0)
            {
			   b[nx][ny]=1;
			   dfs(nx,ny);
			   }
		 }
		else if(b[nx][ny]==0&&i>=2)
		{
           if(a[s[nx][ny]-'A'][i-2]!=0&&a[s[x1][y1]-'A'][i]!=0)
            {
			  	b[nx][ny]=1;
			  dfs(nx,ny);
				}
		}
	}
	return ;
}
int main()
{

	int i,j,k;
	while(scanf("%d%d",&m,&n),m+n>0)
	{
		x=0;
		memset(b,0,sizeof(b));
		memset(s,0,sizeof(s));
		for(i=0;i<m;i++)
		 scanf("%s",s[i]);
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(b[i][j]!=1)
				{
				  dfs(i,j);
				    x++;
				 }
			}
		}
		printf("%d\n",x);
	}
	return 0;
}
   
   


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值