Farm Irrigation

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

Figure 1在这里插入图片描述

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like

Figure 2在这里插入图片描述

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A’ to ‘K’, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
Output
For each test case, output in one line the least number of wellsprings needed.
Sample Input
2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1
Sample Output
2
3

题意:根据已给的田地中渠道,只有渠道相连且有井才能保证田地有收成,求所给田地最少要多少口井。
思路:所给的图片中每个田地的渠道口是不一样的。所有只有判断上下左右的渠道的联通情况。
上联通:ABEGHJK
下联通:CDEHIJK
左联通:ACFGHIK
右联通:BDFGIJK
根据上下左右联通情况来判断最少需要多少口井
在这里插入代码片
#include"cstdio"
#include"cstring"
#include"iostream"
#include"algorithm"
using namespace std;
char ma[661][661];//注意开大一点~
int pre[12121211];
int n,m;
void init()
{
	for(int i=0;i<n*m;i++)
	{
		pre[i]=i;
	}
}
int find(int a)
{
    while(a!=pre[a])
        a = pre[a];
    return a;
}
void join(int a, int b)
{
    int x = find(a);
    int y = find(b);
    if(x!=y)
        pre[y] = x;
}
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        if(n<0||m<0)
            break;
        for(int i=0;i<n;i++)
        {
        	cin>>ma[i];
        }   
        init();
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(i>=1&&(ma[i][j]=='A'||ma[i][j]=='B'||ma[i][j]=='E'||ma[i][j]=='G'||ma[i][j]=='H'||ma[i][j]=='J'||ma[i][j]=='K'))//判断此时是否是上联通
                {
                    if(ma[i-1][j]=='C'||ma[i-1][j]=='D'||ma[i-1][j]=='E'||ma[i-1][j]=='H'||ma[i-1][j]=='I'||ma[i-1][j]=='J'||ma[i-1][j]=='K')//看看上一行的下联通是否成立
                        join((i-1)*m+j, i*m+j);//合并
                }
                 if(j>=1&&(ma[i][j]=='A'||ma[i][j]=='C'||ma[i][j]=='F'||ma[i][j]=='G'||ma[i][j]=='H'||ma[i][j]=='I'||ma[i][j]=='K'))//判断此时是否是左联通
                {
                    if(ma[i][j-1]=='B'||ma[i][j-1]=='D'||ma[i][j-1]=='F'||ma[i][j-1]=='G'||ma[i][j-1]=='I'||ma[i][j-1]=='J'||ma[i][j-1]=='K')//看看左边的点的右联通是否成立
                        join(i*m+j-1, i*m+j);//合并
                }
            }
        }
        int ans = 0;//有几个祖先,就要打几口井
        for(int i=0;i<n*m;i++)
        {
            if(pre[i]==i)
                ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值