poj 1125

                                                                                                                       Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37634 Accepted: 20934

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10
题目大意:
只想说这题的题意真是难啊,看的我头晕,之后还是要去看人家的题解。大意是输入n,表示有n个点,之后有
n行,每行第一个是m,代表后面有m对整数,每对整数中第一个代表第i个点与其相连接,第二个整数代表权值
让找到一个点能到达其他各点,并且权值最小,输出该点编号,以及去做你之中的最大值。
解题思路:
相比题意而言,解决该题还是很容易的,floyd求多源最短路,之后判断,输出即可,题目数据比较水,没有都
不联通的情况,因此不用考虑该情况,虽然题目上说的有。
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 99999999
int main()
{
       int i,j,k,m,n,x,y;
       int f[110][110];
       while(scanf("%d",&n),n!=0)
       {
            for(i=0;i<=n;i++)
               for(j=0;j<=n;j++)
                 { f[i][j]=inf;}
             for(i=1;i<=n;i++)
                 {
                  scanf("%d",&m);
                  for(j=1;j<=m;j++)
                   {
                      scanf("%d%d",&x,&y);
                        f[i][x]=y;
                    }
                  }
            
              for(i=1;i<=n;i++)
              {
                  for(j=1;j<=n;j++)
                  {
                     for(k=1;k<=n;k++)
                        { 
                         f[j][k]=min(f[j][k],f[j][i]+f[i][k]);
                         }
                   }
               }
               x=inf;
               for(i=1;i<=n;i++)
               {
                  y=0;
                  for(j=1;j<=n;j++)
                  {
                     if(i==j)
                        continue;
                     else
                         y=max(f[i][j],y);
                  }
                  if(x>y)
                  {
                     x=y;
                     k=i;
                  }
               }
               if(!k)
               printf("disjoint\n");
               else
               printf("%d %d\n",k,x);
        }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值