11-散列2 Hashing (25 分)

11-散列2 Hashing (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10
​4
​​ ) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

Note

1.题意: 二次探测再散列, 除留余数, 若不是素数找 NextPrime
2. 错误三个点, 上机题目简化版哇,

Code

#include<iostream>
#include<cmath>
using namespace std;
#define MAX 11000
int hashTable[MAX], a[MAX];
int num, tablein;
int NextPrime(int n){
    if(n==1)    return 2;
    int p = (n%2==1) ? n+2 : n+1;
    while (1) {
        int i;
        for(i=3; i*i<=p; i+=2){
            if(p%i == 0)    break;
        }
        if(i*i > p) break;
        else    p += 2;
    }
    return p;
}
char Hash ( int Key, int P )
{   
    int address = Key % P;                        
    for(int i = 0; i <= P; i++){
        address = (address + i*i) % P;
        if(!hashTable[address]){
            hashTable[address] = 1;
            return address + '0'; 
        }
    }
    return '-';
}

int main() {
    cin >> tablein >> num;
    tablein = NextPrime(tablein);
    for(int i = 0; i < num; i++){
        cin >> a[i];
        hashTable[i] = 0;
    }
    cout << Hash(a[0], tablein);
    for(int i = 1; i < num; i++){
        cout << " " << Hash(a[i], tablein);
    }
    return 0;
}

Result

在这里插入图片描述

Note2

  1. 2,3错误原因为char类型只有八位且 ‘0’ + 10 != ‘10’
  2. quadratic probing 的意思是 hi=(h(key)+i*i)%m (0≤i≤m-1)
  3. i的取值到 m - 1 就停止是因为m —— 2m-1 重复于 0 ——m - 1

Code2

#include<iostream>
#include<cmath>
using namespace std;
#define MAX 11000
int hashTable[MAX], a[MAX];
int num, tablein;
int NextPrime(int n){
    if(n==1)    return 2;
    int p = (n%2==1) ? n+2 : n+1;
    while (1) {
        int i;
        for(i=3; i*i<=p; i+=2){
            if(p%i == 0)    break;
        }
        if(i*i > p) break;
        else    p += 2;
    }
    return p;
}
int Hash ( int Key, int P )
{   
    int ptr = Key % P;                        
    for(int i = 0; i <= P - 1; i++){
        int address = (ptr + i*i) % P;
        if(!hashTable[address]){
            hashTable[address] = 1;
            return address; 
        }
    }
    return -1;
}

int main() {
    cin >> tablein >> num;
    tablein = NextPrime(tablein);
    for(int i = 0; i < num; i++){
        cin >> a[i];
        hashTable[i] = 0;
    }
    int temp = Hash(a[0], tablein);
    if(temp >= 0)
        cout << temp;
    else cout << "-";
    for(int i = 1; i < num; i++){
        temp = Hash(a[i], tablein);
        if(temp >= 0)
            cout << " " << temp;
        else cout << " -";
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值