11-散列2 Hashing   (25分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSizeTSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSizeMSize (10^4) and N (MSize) which are the user-defined table size and the number of input numbers, respectively. Then NN distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

解析:

散列表长度为4k+3(k是正整数)形式的素数时,平方探测法能探测到整个散列表的空间。

但是本题给的只是素数,所以有不能探测到位置的情况。

当增量k大于等于size时,平方探测就会重复之前的探测,进入一个死循环。

假设散列表大小为Size,那么当增量大于等于Size平方的时候就是在重复之前1平方,2平方...到(size-1)平方的事情。只要把Size平方,(Size+1)平方因式分解一下,就会发现对求余有影响的就是Size加的部分,后面就是一直重复了。) 参考地址

原理没看懂,有空再看

#include <iostream>
#include <vector>
#include <cstdlib>
#include <cmath>
using namespace std;
int NextPrime ( int N ) {
	if ( N == 1 ) //1既不是素数,也不是合数; 2是素数
		return 2;
	int i, p = ( N % 2 ) ? N + 2 : N + 1;
	while (1) {
		double q = p;
		for ( i = sqrt(q); i > 2; i-- )
			if ( !( p % i ) ) break;
		if ( i == 2 ) return p;
		else p += 2;
	}
}
int IsPrime ( int n ) {
	if ( n == 1 ) 
		return 0;
	else if ( n == 2 )
		return 1;
	else {
		int k = sqrt(n);
		for ( int i = 2; i <= k; i++ )
			if ( n % i == 0 )
				return 0;
		return 1;
	}
}
int main () {
	int MSize, TSize, N, key, pos, tmp, k;
	cin >> MSize >> N;
	if ( IsPrime( MSize ) )
		TSize = MSize;
	else
		TSize = NextPrime( MSize );
	//用数组建立散列表
	vector<int> v(TSize);
	for ( int i = 0; i < TSize; i++ )  //散列表初始化为0,方便判断位置上有无元素
		v[i] = 0;
	//将元素插入散列表并输出下标
	for ( int i = 0; i < N; i++ ) {
		cin >> key;
		pos = key % TSize;
		k = 0; tmp = pos;
		while ( k < TSize ) {  //k>=size后,平方探测将进入一个死循环
			if ( v[pos] == 0 ) { //如果该位置没有元素
				v[pos] = key;
				cout << pos;
				break;
			}
			else { //该位置有元素,使用平方探测法解决冲突
				k++;
				pos = ( tmp + k * k ) % TSize; 
			}
		}
		if ( k == TSize ) //没找到
			cout << "-";
		if ( i != N - 1 ) //最后一个元素后面不要空格
			cout << " ";
	}
	system("pause");
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值