【贪心/线性DP】Monkey and Banana(HDU-1069)

【线性DP】Monkey and Banana(HDU-1069)

题目链接

题目

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

思路

机翻题目
一组研究人员正在设计一个实验,以测试猴子的智商。他们将在建筑物的屋顶上悬挂一根香蕉,同时为猴子提供一些障碍。如果猴子足够聪明,则可以通过将一个块放在另一个块上来建造塔,然后爬上去以获得最喜欢的食物,从而到达香蕉。

研究人员拥有n种类型的积木,每种类型的积木数量不受限制。每个i型块都是具有线性尺寸(xi,yi,zi)的矩形实体。可以重新调整块的方向,以便使其三个尺寸中的任意两个确定底座的尺寸,另一个尺寸是高度。

他们希望通过堆叠砖块确保最高的塔可以到达屋顶。问题是,在建造塔楼时,一个块只能放置在另一个块的顶部,只要上部块的两个基本尺寸都严格小于下部块的相应基本尺寸,因为必须给猴子一些空间。例如,这意味着不能堆叠定向为具有相等大小的底部的块。

您的工作是编写一个程序,该程序确定猴子可以使用给定的一组积木建造的最高塔的高度。

大概是
贪心排序+LIS问题
回忆一下基本的LIS问题,序列顺序是确定的,这题看起来不确定顺序,实际上可以通过贪心的方式来排序,我们只需要先排面积然后排长度即可得到固定的顺序,这样问题转化成LIS问题。

代码

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll n,C,ans;
const int N=1e3+10;
struct Cube
{
    ll x,y,z,s;
}F[N];
ll dp[N];
bool cmp(Cube a,Cube b)
{
    if(a.s!=b.s)return a.s>b.s;
    if(a.y!=b.y)return a.y>b.y;
    if(a.x!=b.x)return a.x>b.x;
}
int main()
{
    while(~scanf("%lld",&n)&&n)
    {
        memset(dp,0,sizeof dp);
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            ll a,b,c;
            scanf("%lld%lld%lld",&a,&b,&c);
            if(a>b)swap(a,b);
            if(a>c)swap(a,c);
            if(b>c)swap(b,c);
            F[cnt+1]={a,b,c,a*b};
            F[cnt+2]={a,c,b,a*c};
            F[cnt+3]={b,c,a,b*c};
            F[cnt+4]={b,a,c,b*a};
            F[cnt+5]={c,a,b,a*c};
            F[cnt+6]={c,b,a,b*c};
            cnt+=6;
        }
        sort(F+1,F+1+cnt,cmp);
        for(int i=1;i<=cnt;i++)dp[i]=F[i].z;
        for(int i=1;i<=cnt;i++)
        {
            for(int j=1;j<i;j++)
            {
                if(F[i].x<F[j].x&&F[i].y<F[j].y)dp[i]=max(dp[i],dp[j]+F[i].z);
            }
        }
        ll ans=0;
        for(int i=1;i<=cnt;i++)ans=max(ans,dp[i]);//不是dp[n]啊
        C++;
        printf("Case %lld: maximum height = %lld\n",C,ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值