2021-07-21 PK赛 lower_bound( )和upper_bound( )的应用

在这里插入图片描述

PK赛
总时间限制:
1000ms

内存限制:
65535kB
描述
在一次学校的活动中,有一个老师和学生的PK。其中ai是教师的得分和bi为学生的得分。
如果ai+aj>bi+bj(即老师胜),问最后老师胜的次数是多少次?

输入
多组数据输入的第一行包含一个整数n (2≤n≤2*10^5)——评分的数量。输入的第二行包含n个整数a1,a2,…,an(1≤ai≤109),其中ai为教师第i个评分。输入的第三行包含n个整数b1,b2,…,bn(1≤bi≤109),其中bi为学生第i个评分。
输出
打印一个整数老师胜利的数量。
样例输入
5
4 8 2 6 2
4 5 4 1 3
4
1 3 2 4
1 3 2 4
样例输出
7
0

一开始是这样写的,结果显示超时

#include<iostream>
#include<cstdio>
#define Maxn 100000
using namespace std;

int com[Maxn],t[Maxn],s[Maxn];
int main()
{
    int n;
    int cnt;
    while(cin>>n)
    {
        cnt=0;
        for(int j=0;j<n;++j) scanf("%d",&t[j]);
        for(int j=0;j<n;++j){
             scanf("%d",&s[j]);
             com[j]=t[j]-s[j];
        }
        for(int i=0;i<n-1;++i)
        {
            for(int j=i+1;j<n; ++j)
            {
                if(com[i]+com[j]>0){
                    cnt++;
                }
             }
        }
        cout<<cnt<<endl;
    }
    return 0;
}

经过查询,用lower_bound( )会省去很多时间

lower_bound( )和upper_bound( )
转载自:关于lower_bound( )和upper_bound( )的常见用法_brandong-CSDN博客_lower_bound

lower_bound( )和upper_bound( )都是利用二分查找的方法在一个排好序的数组中进行查找的。

在从小到大的排序数组中,

lower_bound( begin,end,num):从数组的begin位置到end-1位置二分查找第一个大于或等于num的数字,找到返回该数字的地址,不存在则返回end。通过返回的地址减去起始地址begin,得到找到数字在数组中的下标。

upper_bound( begin,end,num):从数组的begin位置到end-1位置二分查找第一个大于num的数字,找到返回该数字的地址,不存在则返回end。通过返回的地址减去起始地址begin,得到找到数字在数组中的下标。

在从大到小的排序数组中,重载lower_bound()和upper_bound()

lower_bound( begin,end,num,greater() ):从数组的begin位置到end-1位置二分查找第一个小于或等于num的数字,找到返回该数字的地址,不存在则返回end。通过返回的地址减去起始地址begin,得到找到数字在数组中的下标。

upper_bound( begin,end,num,greater() ):从数组的begin位置到end-1位置二分查找第一个小于num的数字,找到返回该数字的地址,不存在则返回end。通过返回的地址减去起始地址begin,得到找到数字在数组中的下标。

#include<bits/stdc++.h>
using namespace std;
const int maxn=100000+10;
const int INF=2*int(1e9)+10;
#define LL long long
int cmd(int a,int b){
    return a>b;
}
int main(){
    int num[6]={1,2,4,7,15,34};
    sort(num,num+6);                           //按从小到大排序
    int pos1=lower_bound(num,num+6,7)-num;    //返回数组中第一个大于或等于被查数的值
    int pos2=upper_bound(num,num+6,7)-num;    //返回数组中第一个大于被查数的值
    cout<<pos1<<" "<<num[pos1]<<endl;
    cout<<pos2<<" "<<num[pos2]<<endl;
    sort(num,num+6,cmd);                      //按从大到小排序
    int pos3=lower_bound(num,num+6,7,greater<int>())-num;  //返回数组中第一个小于或等于被查数的值
    int pos4=upper_bound(num,num+6,7,greater<int>())-num;  //返回数组中第一个小于被查数的值
    cout<<pos3<<" "<<num[pos3]<<endl;
    cout<<pos4<<" "<<num[pos4]<<endl;
    return 0;
}

改进后

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=200006;
ll a[maxn],b[maxn],c[maxn];
int main() {
    int n;
    while(cin>>n)
    {
        for(int i=1; i<=n; i++) cin>>a[i];
        for(int i=1; i<=n; i++) {
            cin>>b[i];
            c[i]=a[i]-b[i];
        }
        sort(c+1,c+n+1);
        ll sum=0;
        for(int i=1; i<=n; i++) {
            ll k=upper_bound(c+i+1,c+n+1,-c[i])-c;
            sum+=n-k+1;
        }
        cout<<sum<<endl;
    }
    return 0;  }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

泥烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值