2021-08-20 AcWing 3810. 最长连续休息时间

输入样例:

4
5
1 0 1 0 1
6
0 1 0 1 1 0
7
1 0 1 1 1 0 1
3
0 0 0

输出样例:

2
2
3
0

 

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

const int N = 400010;
vector<int> a(N);
int main()
{
    int t,n;
    cin >> t;
    while(t--)
    {
        cin >> n;
        int cnt=0;
        int maxx=-1;
        for (int i = 0; i < n; i ++ )
        {
            scanf("%d", &a[i]);
            a[n+i]=a[i];
            
        }
        for (int i = 0; i < 2*n; i ++ ){
            if(a[i]){
                cnt++;
            }else{
                cnt=0;
            }
            maxx = max(cnt,maxx);
        }
        cout <<maxx << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

泥烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值