[D-OJ练习] 求二叉树的深度

采用先序法建立一棵二叉树,设计求该二叉树的深度,二叉树的数据域类型为字符型,扩展二叉树的叶子结点用‘#’表示,要求可以求多棵二叉树的深度,当二叉树的深度为0时程序结束。

输入描述

 
      

循环输入多棵扩展二叉树的先序遍历序列,每棵树占一行,以回车结束,每棵二叉树中结点之间以空格隔开

输出描述

 
      

输出各二叉树的深度,每次输出后面都换行

输入样例

A B # # C D # E # F # # G H # I K # # # #
A B D H # # I # # E J # # K # # C F L # # M # # G N # # O # #
#

输出样例

6
4
0

#include<iostream>
#include<algorithm>
using namespace std;

struct BiNode {
	char ch;
	BiNode* lchirld, * rchirld;
};

class BiTree {
private:
	BiNode* root;
	BiNode* Create();
	void Realse(BiNode* bt);
	int CountDepth(BiNode* bt);
public:
	BiTree() {
		root = Create();
	}
	~BiTree() {
		Realse(root);
	}
	int CountDepth() {
		return CountDepth(root);
	}
};


BiNode* BiTree::Create() {
	BiNode* bt;
	char ch;
	cin >> ch;
	if (ch == '#') bt = NULL;
	else {
		bt = new BiNode;
		bt->ch = ch;
		bt->lchirld = Create();
		bt->rchirld = Create();
	}
	return bt;
}

void BiTree::Realse(BiNode* bt) {
	if (!bt) return;
	else {
		Realse(bt->lchirld);
		Realse(bt->rchirld);
		delete bt;
	}
}

int BiTree::CountDepth(BiNode* bt) {
	if (!bt) return 0;
	else {
		int leftDepth = CountDepth(bt->lchirld);
		int rightDepth = CountDepth(bt->rchirld);
		
		return 1 + max(leftDepth, rightDepth);
	}
}
int main()
{
	int isContinue = 1;	
	while(isContinue)
	{
		BiTree tree;
		cout << tree.CountDepth();
		if(!tree.CountDepth()) isContinue = 0;
	}
	return 0;
}

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

泥烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值