PAT甲组 1071. Speech Patterns (25)

1071. Speech Patterns (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:
Can1: "Can a can can a can?  It can!"
Sample Output:
can 5

题意:给一个字符串,输出其中出现次数最多的词和次数(单词仅由字母和数字组成,字母不分大小写,最后统一小写输出)。

思路:用map存每个单词出现的次数,用非单词构成字符切割单词。PS:可能有连续的非法字符,用while吃光比较合适。有可能出现开头就是非法字符的情况,要判断单词字符串非空才能在map里找它。

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
#include<map>
#include<vector>
#include<set>
using namespace std;

bool book(char c)//判断是不是有效字符
{
	if(c<='Z'&&c>='A') return true;
	if(c<='z'&&c>='a') return true;
	if(c<='9'&&c>='0') return true;
	return false;
}

map<string,int>mp;
string a,c,ans;
int i;

int main()
{
	getline(cin,a);
	while(i<a.size())
	{
		c.clear();
		while(i<a.size()&&book(a[i])==true)
		{
			if(a[i]<='Z'&&a[i]>='A')
				a[i]+=32;
			c+=a[i];
			i++;
		}
		if(c!="")
		{
			if(mp.find(c)==mp.end())//没有出现过的单词
				mp[c]=1;
			else
				mp[c]++;//出现过,加次数
		}
		while(i<a.size()&&book(a[i])==false)//非法字符
			i++;
	}
	int maxx=-1;
	for(map<string,int>::iterator it=mp.begin();it!=mp.end();it++)
	{
		if(it->second>maxx)
		{
			maxx=it->second;
			ans=it->first;
		}
	}
	cout<<ans<<" "<<maxx<<endl;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值