PAT甲组 1039. Course List for Student (25)

1039. Course List for Student (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意:和1047反了一下输入和输出,1047题解传送门http://blog.csdn.net/qq_39396954/article/details/79245214

第一行给出N和K,代表N个查询,K个课程,接下来每个课程占两行,第一行是课程编号C以及选择的人数P,第二行就是选择的同学的姓名列表。最后一行给出N个名字,代表N个查询,要按顺序输出这些同学的名字,选择课程的数目,按升序排序该同学选择的课程编号。

思路:这题的最后一组数据量可大了,很容易超时,用二维数组会爆内存,得用vector,map和string还有cin和cout会超时,让人头大。学到了把每个同学的名字转换成数字编号的hash(散列)的方法,很好用。

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
#include<map>
#include<vector>
#include<set>
using namespace std;
const int maxv = 26*26*26*10;

vector<int>P_C[maxv];//用vector存某编号同学选择的课程

int name_num(char a[])//将名字转化成编号
{
	int num=0;
	for(int i=0;i<=2;i++)
	{
		num=num*26+(a[i]-65);
	}
	num=num*10+a[3]-'0';
	return num;
}

int N,K,C,P;
char name[5];

int main()
{
	scanf("%d %d",&N,&K);
	for(int i=0;i<K;i++)
	{
		scanf("%d %d",&C,&P);
		for(int i=0;i<P;i++)
		{
			scanf("%s",name);
			P_C[name_num(name)].push_back(C);
		}
	}
	for(int i=0;i<N;i++)
	{
		scanf("%s",name);
		sort(P_C[name_num(name)].begin(),P_C[name_num(name)].end());
		printf("%s %d",name,P_C[name_num(name)].size());
		for(int i=0;i<P_C[name_num(name)].size();i++)
		{
			printf(" %d",P_C[name_num(name)][i]);
		}
		puts("");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值