C++标准模板库的使用(string)

1. 问题描述:

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3

题目来自于PAT A 1060:Are They Equal?题目是英文题目,下面是题目的大题意思:

给出两个数,问:将它们写成保留N位小数的科学计数法后是否相等,如果相等,则输出YES,并给出该转换结果;如果不等则输出NO,并分别给出两个数的转换结果

样例解释:

12300与12358.9的保留三位数字的科学计数法均为0.123 * 10 ^ 5,则输出YES

样例二:120与128保留三位小数的科学计数法是0.120 * 10 ^ 3与0.128 * 10 ^ 3,则输出"NO"

题目的要求是将两个数字改写为科学计数法的形式然后判断他们是否相等,而科学计数法的写法一定是如下格式:0.a1a2a3...* 10 ^ e因此只需要获取到科学计数法的本体部分a1a2a3与指数e那么即可判断出两个数在科学计数法的形式是否相等

2. 思路分析:

① 先考虑数据本身,可以想到按整数部分是否为0来分情况讨论,即:

1)0.a1a2a3...

2)b1b2...bm.a1a2a3...

对于1)来说小数点之后可能还有若干个的0,因此本题部分是小数点之后非零开始的3位,而指数是小数点与该非零位之间的0的个数的相反数(0.001的指数为-2)所以我们在小数点之后每出现一个零那么就让e减去1,直到到达最后一位

对于2)的情况,假设b1不为零,很显然本体部分就是从b1开始的三位,而指数则是小数点前的的数位的总位数m,具体实现中则可以令指数e的初值是0,从前往后扫描,只要是不遇到最后一位或者是小数点那么就让e的位数加1

3)如何区分是哪一种情况呢?题目中说可能出现签到零所以我们在输入数据的时候第一步就是去除前导零,这样就可以判断去除之后的字符串的第一位是否是小数点来进行判断

3. 下面是具体的代码:

#include<iostream>
#include<string>
using namespace std;
int n;
string deal(string s, int &e){
	int k = 0;
	while(s.length() > 0 && s[0] == '0'){
		s.erase(s.begin());	
	}
	if(s[0] == '.'){
		s.erase(s.begin());
		while(s.length() > 0 && s[0] == '0'){
			s.erase(s.begin());
			e--;
		}
	}else{
		while(k < s.length() && s[k] != '.'){
			k++;
			e++;
		}	
		if(k < s.length()){
			s.erase(s.begin() + k);
		}
	}
	if(s.length() == 0){
		e = 0;
	}
	int num = 0;
	k = 0;
	string res;
	while(num < n){
		if(k < s.length()) res += s[k++];
		else{
			res += '0';
		}
		num++;
	}
	return res;
} 
int main(void){
	string s1, s2, s3, s4;
	cin >> n >> s1 >> s2;
	int e1 = 0, e2 = 0;
	s3 = deal(s1, e1);
	s4 = deal(s2, e2);
	if(s3 == s4 && e1 == e2){
		cout << "YES 0." << s3 << "*10^" << e1 << endl;
	}else{
		cout << "NO 0." << s3 << "*10^" << e1 << " 0." << s4 << "*10^" << e2 << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值