POJ1328

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


Figure A Sample Input of Radar Installations

 

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

 

题意:每个雷达有个覆盖范围,求覆盖所有岛屿的最少雷达数

思路:贪心策略,为了使雷达数量最少,肯定是将雷达尽量设置在右边的位置。所以预处理所有的岛屿,求出覆盖每座岛屿的x坐标的取值范围,然后按最右边范围从小到大排序,依次选取和检查即可。

#include<cstdio>
#include<string.h>
#include<queue>
#include<vector>
#include<map>
#include<stack>
#include<set>
#include<algorithm>
#include<map>
#include<math.h>
using namespace std;
#define INF 1<<28
static const int MAX = 1050;
int n, d;

struct island{
    int x, y;
    double l, r;    //每个点的左右边界

    //按范围的最大取值横坐标升序排序
    bool operator < (const struct island &p)
    {
        return r < p.r;
    }
}A[MAX];

//在岸上找一个点,该点越靠近右边越好
int main()
{
    int k = 1;
    while (scanf("%d %d", &n, &d) && n && d)
    {
        bool nosolution = false;
        int cnt = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%d %d", &A[i].x, &A[i].y);
            if (A[i].y > d)
                nosolution = true;
        }
        if (nosolution)
            printf("Case %d: -1\n", k++);
        else
        {
            for (int i = 0; i < n; i++)
            {
                A[i].l = A[i].x - (double)sqrt((double)d * d - (double)A[i].y * A[i].y);
                A[i].r = A[i].x + (double)sqrt((double)d * d - (double)A[i].y * A[i].y);
            }
            sort(A, A + n);

            for (int i = 0; i < n; )
            {
                double p = A[i].r;
                while (p >= A[i].l && p <= A[i].r)
                    i++;
                cnt++;
            }
            printf("Case %d: %d\n", k++, cnt);
        }
    }
    return 0;
}







 

  • 2
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
根据您的问题,我理解您想了解POJ1328问题的Java解决方案。POJ1328是一个经典的问题,也被称为"雷达安装"问题,它涉及到在一个二维平面上安装雷达以覆盖所有岛屿的最小雷达数量。以下是一个Java解决方案的示例代码: ```java import java.util.Arrays; import java.util.Comparator; import java.util.Scanner; public class Main { public static void main(String[] args) { Scanner scanner = new Scanner(System.in); int caseNum = 1; while (true) { int n = scanner.nextInt(); if (n == 0) { break; } Island[] islands = new Island[n]; for (int i = 0; i < n; i++) { int x = scanner.nextInt(); int y = scanner.nextInt(); islands[i] = new Island(x, y); } int radarNum = getRadarNum(islands); System.out.println("Case " + caseNum + ": " + radarNum); caseNum++; } } private static int getRadarNum(Island[] islands) { Arrays.sort(islands, Comparator.comparingInt(Island::getRight)); int radarNum = 1; int rightMost = islands[0].getRight(); for (int i = 1; i < islands.length; i++) { if (islands[i].getLeft() > rightMost) { radarNum++; rightMost = islands[i].getRight(); } else { rightMost = Math.min(rightMost, islands[i].getRight()); } } return radarNum; } static class Island { private int left; private int right; public Island(int left, int right) { this.left = left; this.right = right; } public int getLeft() { return left; } public int getRight() { return right; } } } ``` 这段代码通过输入岛屿的坐标,计算出需要安装的最小雷达数量,并输出结果。它使用了排序和贪心算法的思想来解决问题。
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值