KazaQ's Socks

KazaQ's Socks


KazaQ wears socks everyday.

At the beginning, he has
n n pairs of socks numbered from 1 1 to n n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are
n1 n−1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the
k k-th day.

Input
The input consists of multiple test cases. (about 2000 2000 )

For each case, there is a line contains two numbers
n,k n,k (2n109,1k1018) (2≤n≤109,1≤k≤1018) .
Output
For each test case, output " Case # x x: y y" in one line (without quotes), where x x indicates the case number starting from 1 1 and y y denotes the answer of corresponding case.
Sample Input
3 7
3 6
4 9
Sample Output
Case #1: 3
Case #2: 1
Case #3: 2


官方题解:找规律即可。规律是 $\underbrace{1, 2, \cdots, n}_{n\text{ numbers}},$ $\underbrace{1, 2, \cdots, n - 1}_{n - 1\text{ numbers}},$ $\underbrace{1, 2, \cdots, n - 2, n}_{n - 1\text{ numbers}},$ $\underbrace{1, 2, \cdots, n - 1}_{n - 1\text{ numbers}},$ $\underbrace{1, 2, \cdots, n - 2, n}_{n - 1\text{ numbers}},$ ⋯\cdots
开始规律找错了(orz),结果队友自己找出来了。
其实自己模拟一下规律还是很明显的。
以3为例;
1 2 3 1 2 1 3 1 2 1 3
以4为例
1 2 3 4 1 2 3 1 2 4 1 2 3 1 2 4
就是n-k之后出现了一个奇偶的循环

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

typedef long  long ll;

ll n,k;
int main()
{
    int kase=1;
    while(scanf("%lld%lld",&n,&k)!=EOF)
    {
        if(n>=k)
            printf("Case #%d: %d\n",kase++,k);
        else
        {
            ll a=(k-n)/(n-1);
            ll b=(k-n)%(n-1);
            if(a&1)
            {
                if(b==0)
                    printf("Case #%d: %d\n",kase++,n-1);
                else
                    printf("Case #%d: %d\n",kase++,b);
            }
            else
            {
                if(b==0)
                    printf("Case #%d: %d\n",kase++,n);
                else
                    printf("Case #%d: %d\n",kase++,b);
            }
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值