【UVA】1368 DNA Consensus String

题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=4114

目录

题目:

Input

Output

Sample Input

Sample Output

分析:

代码:


 

题目:

DNA (Deoxyribonucleic Acid) is the molecule which contains the genetic instructions. It consists of four different nucleotides, namely Adenine, Thymine, Guanine, and Cytosine as shown in Figure 1. If we represent a nucleotide by its initial character, a DNA strand can be regarded as a long string (sequence of characters) consisting of the four characters A, T, G, and C. For example, assume we are given some part of a DNA strand which is composed of the following sequence of nucleotides:

      “Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-CytosineCytosine-Guanine-Adenine-Thymine”

Then we can represent the above DNA strand with the string “TAACTGCCGAT.”

The biologist Prof. Ahn found that a gene X commonly exists in the DNA strands of five different kinds of animals, namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal were very alike. See Figure 2.

                                                           DNA sequence of gene X

                                                            Cat: GCATATGGCTGTGCA

                                                           Dog: GCAAATGGCTGTGCA

                                                        Horse: GCTAATGGGTGTCCA

                                                          Cow: GCAAATGGCTGTGCA

                                                     Monkey: GCAAATCGGTGAGCA

                                              Figure 2. DNA sequences of gene X in five animals.

Prof. Ahn thought that humans might also have the gene X and decided to search for the DNA sequence of X in human DNA. However, before searching, he should define a representative DNA sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He decided to use the Hamming distance to define the representative sequence.

The Hamming distance is the number of different characters at each position from two strings of equal length. For example, assume we are given the two strings “AGCAT” and “GGAAT.” The Hamming distance of these two strings is 2 because the 1st and the 3rd characters of the two strings are different. Using the Hamming distance, we can define a representative string for a set of multiple strings of equal length. Given a set of strings S = {s1, . . . , sm} of length n, the consensus error between a string y of length n and the set S is the sum of the Hamming distances between y and each si in S. If the consensus error between y and S is the minimum among all possible strings y of length n, y is called a consensus string of S. For example, given the three strings “AGCAT” “AGACT” and “GGAAT” the consensus string of the given strings is “AGAAT” because the sum of the Hamming distances between “AGAAT” and the three strings is 3 which is minimal. (In this case, the consensus string is unique, but in general, there can be more than one consensus string.) We use the consensus string as a representative of the DNA sequence. For the example of Figure 2 above, a consensus string of gene X is “GCAAATGGCTGTGCA” and the consensus error is 7.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing two integers m and n which are separated by a single space. The integer m (4 ≤ m ≤ 50) represents the number of DNA sequences and n (4 ≤ n ≤ 1000) represents the length of the DNA sequences, respectively. In each of the next m lines, each DNA sequence is given.

Output

Your program is to write to standard output. Print the consensus string in the first line of each case and the consensus error in the second line of each case. If there exists more than one consensus string, print the lexicographically smallest consensus string.

Sample Input

3

5 8

TATGATAC

TAAGCTAC

AAAGATCC

TGAGATAC

TAAGATGT

4 10

ACGTACGTAC

CCGTACGTAG

GCGTACGTAT

TCGTACGTAA

6 10

ATGTTACCAT

AAGTTACGAT

AACAAAGCAA

AAGTTACCTT

AAGTTACCAA

TACTTACCAA

Sample Output

TAAGATAC

7

ACGTACGTAA

6

AAGTTACCAA

12 

分析:

大体意思是说,根据给出m个长度不超过n的DNA字符串。求出一个DNA串,使得其对给出的DNA串的汉明距离之和最小。 (汉明距离指两字符串 对应位置字符不同的个数)。(本来理解错了题意,以为是从给出的串中找一个最小的,一带样例发现结果不对。应该是自己通过给出的串,求一个与给出DNA串等长的DNA串)

求汉明距离和最小,只需求每个位置出现最多的字符并输出。汉明距离则为 总字符个数 - 每个位置出现最多字符的次数。

代码:

#include <stdio.h>
#include <string.h>
int main()
{
	int fre[1005][26],max[1005],result;//记录最常出现次数相关
	char dna[50][1005],ans[1005];
	int m,n,i,j,T;
	char c;
	scanf("%d",&T);
	while (T--)
	{
		result = 0;
		memset(dna,0,sizeof(dna));
		memset(fre,0,sizeof(fre));
		memset(max,0,sizeof(max));
		memset(ans,0,sizeof(ans));
		scanf("%d%d",&m,&n);
		for (i=0; i<m; i++)
		{
			scanf("%s",dna[i]);
		}
		for (j=0 ;j<n; j++)//记录每列A C G T出现的顺序
		{
			for (i=0; i<m; i++)
			{
				c = dna[i][j];
				fre[j][c-'A']++;
			}
		}
		
		for (j=0; j<n; j++)//求出每个位置出现最多的字符
		{
			ans[j] = 'A';
			max[j] = fre[j]['A'-'A'];
			if (fre[j]['C'-'A']>max[j]) { ans[j]='C'; max[j] = fre[j]['C'-'A'];}
			if (fre[j]['G'-'A']>max[j]) { ans[j]='G'; max[j] = fre[j]['G'-'A'];}
			if (fre[j]['T'-'A']>max[j]) { ans[j]='T'; max[j] = fre[j]['T'-'A'];}
			result +=max[j];
		}
		
		for (j=0; j<n; j++)
		{
			printf("%c", ans[j]);
		}
		printf("\n%d\n", m*n-result); 
	}	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值